GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Default 2003 GMC Envoy AC Problems

    I have a 03 gmc envoy and the ac blows cold on the driverside and hot on the passengerside. I disconnected the battery and when I connected it this problem occurred.

  2. #2

    Default

    Welcome to the club man, I don't know what to tell you with your vent problem but I'm sure you will find the answer on here. Good to have you here.


    2002 Chevrolet Silverado Extended Cab SportSide: See Mods in My Garage

  3. #3

    Default

    welcome to the club and unfortunately like donyms i cant help you hopefully some one will come along that can
    Go-Recon "xtreme" amber scanning tail gate light strip, Cobra ultra2 CB radio W/ 4 foot firestix antennas, dual exhaust with 40 series single in dual out muffler, 305/65R17 Mickey Thomson Baja ATZ on 17 inch Mickey Thompson Side Biters, 3 inch body lift

    "when the going gets tough the tough get cyclic:fighting0019:"
    "use the force luke:fighting0040:"

  4. #4

    Default

    sounds to me like the baffle that controls airflow some how get stuck between positions when you disconnected from the battery. not sure how you would go about fixing it......

    try googling it.

    Alex


    2011 GMC Sierra SLE 5.3 Z71 4X4 Stealth Gray Metallic / 2004 Chevy Impala LS 3.8 Cappuccino

    Tow mirrors - Diablew Tuned - Flowmaster Regular 40 - Ready Lift 2.5' lift - BFG LT A/T K/Os - Carr Light Wing - TruckLite LED lights - Optima Red Top - 50% Front Window Tint - Line-X bedliner - Airaid MIT - Tekonsha P2 - ARS Billet Grill - Fia custom fit seat covers

  5. #5

    Default

    Thanks to all of you. I will try the baffle. I found the actuator, but it's in a bad location.

  6. #6

    Default

    I have a 03 gmc envoy and the ac blows cold on the driverside and hot on the passengerside. I disconnected the battery and when I connected it this problem occurred.
    "WATSON"

  7. #7

    Default

    Ok james, as suggested above, the problem is the passenger side temperature actuator. It either failed when the battery was reconnected, or it did not reset it'self.

    I had an '05 Envoy and I had an actuator problem after I reconnected the battery. In my case, it did not reset. I was able to get it to reset by disconnecting/reconnecting the battery. I had to do it 3, or 4, times before it reset, I moved the (in your case temp control) to different places each time I tried.

    You can dup the battery dis/re by pulling HVAC fuses, but I don't remember which one(s).

    If the reset does not work, you must change the actuator.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

Similar Threads

  1. 2003 envoy xl heater core
    By malibured in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 10-05-2011, 02:47 PM
  2. 2003 envoy heater core
    By malibured in forum Member Introductions
    Replies: 5
    Last: 10-04-2011, 04:54 PM
  3. 2003 Envoy XL SLT 5.3L V8 Questions
    By cmurphy84 in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 12
    Last: 10-05-2010, 12:16 PM
  4. Envoy 2003
    By mujtaba in forum Member Introductions
    Replies: 11
    Last: 11-23-2009, 02:38 AM
  5. 2003 Envoy - Glaze or wax ?
    By bASSCASTER in forum Chevy Truck Accessories
    Replies: 1
    Last: 03-28-2008, 04:07 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •