GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1

    Default 94 k1500 no spark

    hey all, i have a 94 gmc k1500 and am getting no spark. plugs, wires, cap, rotor, and ignition coil have all been replaced. i am not getting any current out of the ignition coil itself. originally i thought it may be a fuel issue so the fuel pump and filter were both checked and are working properly. what would be the next item to check/replace? sorry if the question has been brought up before but i did a search and couldnt come up with an answer.

  2. #2

    Default

    if it is a vortec check your crank shaft sensor.

    ---------- Post added at 05:40 PM ---------- Previous post was at 05:13 PM ----------

    also check your pick up coil on the distributor

  3. #3
    Sr. Engineer
    Join Date
    Dec 2011
    Location
    11-22-boogie woogie avenue
    Posts
    308

    Default

    What you have changed either the ignition module in side distributor or pickup coil on distributor. shaft.
    Can take ign. module to auto parts for a test . see if it is good.
    RESIDENT NUT.....MY CLAIM TO FAME .....

  4. #4

    Default

    Check all your grounds and check the wire from the battery to your starter...ive seen them go bad and once i replaced them,worked like new!

    2009 Chevrolet Silverado 1500 LT Z71 Crew Cab "All-Star Edition"

    Line-X'd Bed
    Line-X'd Custom Brush Guard(Heavy Duty)
    5.3L Flex Fuel
    275/65R18 Toyo Open Country AT2's
    2" Rough Country Leveling Kit(want to get the 2.5 RC kit)
    EGR In-Channel Vent Visors
    Exterior PLUS Package
    Interior PLUS Package
    K&N Drop-In Air Filter
    ProFlaps
    Cat-Back Dual Exhaust
    Black Bowties
    Diablo Sport Predator(AFM Disabled)
    ProFlaps
    Towing Mirrors
    Next Planned Mods
    Blacked out Tail Lights
    Aftermarket Rims

  5. #5

    Default

    ok, thanks guys i will try those things and see what happens. thanks for the ideas.

  6. #6

    Default

    X2 what Dipstick says on the Ignition Control Module.

    If you have a bad Ground connection, and it looses connection while the engine is running, the Ign. Con. Mod. with fry.
    Pavement sucks... :grrrrrr:



    1994 K1500 4x4 Ext. Cab
    PCM chip and Xenon 8000k bulbs
    350cu.in bored over .050"
    balanced Crank, 10:1 compression
    Flat top pistons,cam,ported heads
    Option Racing Cold Air Intake
    Holley Throttle Body Spacer
    Accell Igition, 45kv coil
    FloTech Headers, no CATs, dual exhuast
    Goodyear Silent Armor A/T 305/70-16
    Pioneer SupertunerIII CD USB Bluetooth
    Kicker ZX200.2 ZX Amp
    Kicker Audio COMP 10" Subwoofer

  7. #7

    Default

    I am having the same problem. I don't know much about engines and am learning as I go, but would a bad ground to the battery have an issue with spark? I'm not trying to be a smartass or anything, just curious.

    conceptualbass1-any luck with the truck, I personally am starting to run out of patience, lol.

  8. #8

    Default

    Yes, that too would be an issue.

    However, you would get nothing when trying to start, let alone a spark issue.

  9. #9

    Default

    So I am having the same problem, and thought maybe I had a ground issue. I replaced the battery to intake ground and now it feels like my truck is going to start, but does not. I also looks like the plugs are not getting fuel because when I pull them, they are dry, but I can smell gas when I try and start my truck.

Similar Threads

  1. 97 Suburban K1500 5.7 won't start, but turns over fine,has spark and is getting fuel.
    By boycbronco in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 8
    Last: 08-26-2011, 07:44 PM
  2. K1500 5.7L Suburban Vortec has no spark
    By barneyfife912a in forum GM Powertrain
    Replies: 0
    Last: 08-11-2011, 09:47 PM
  3. 97-98 k1500 dash compatable with a 95 k1500?
    By Lifted_Bowtie in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 12-11-2010, 04:51 PM
  4. Replies: 0
    Last: 07-30-2010, 07:00 PM
  5. 78 No Spark
    By albatross in forum Chevy C/K Truck Forum
    Replies: 1
    Last: 12-02-2007, 12:50 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •