GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5

Thread: a/c frustration

  1. #1
    Jr. Apprentice
    Join Date
    May 2012
    Location
    Buckholts, Texas
    Posts
    10

    Default a/c frustration

    I decided to tackle my a/c on my '98 c1500. New compressor, accumulator, pressure switch, orifice tube, flush, 36oz. refrigerant, 8oz. PAG oil. Flushed the evaperator and condenser with flush, then with air for 15-20 minutes each. I added 2.5 oz. of oil to the compressor(it already had 1.5oz. from the factory), and I put 4oz. in the accumulator. Blew out the lines, and hooked it all up. Put it on a vacuum pump for about an hour, then left it to see if vacuum held. 2 hours later it still had vacuum. I hooked up my gauge set and put on my first can (12oz.) of 134A. I opened up the low side and proceeded to charge the system. This is where I think I made my mistake...I forgot to turn off the low side between cans, so I think it sucked atmosphere into the system before I realized what I had done. I proceeded with the other two cans anyway. The clutch never engaged during this process, so I jumped it from the battery to facilitate charging. After the third can, with the clutch engaged (jumped) my readings are about 30 on the low side, and about 170 on the high side. When I cut the engine, both sides sit at around 85-90 psi. With the clutch jumped, at the vent it blows 55 degree air, but I think I need about 40 degree air at 80 degrees ambient temperature. Could contamination of the system by air (atmosphere) be the problem? Are my pressures too low to engage the clutch? I'm sure I'll have to go get the a/c serviced now, my only consolation being that it won't involve 400-500 dollars of labor. Thanks in advance for any replies. Steve

    ---------- Post added at 10:36 PM ---------- Previous post was at 10:32 PM ----------

    Oh, and I forgot, the clutch seems to chirp a little when not engaged, what is the proper gap it should have?

  2. #2

    Default

    The air gap should be somewhere between .20 to .30. I could be mistaken, so you'd better double-check.
    The air in the system can mess with it quite a bit. It tends to get in the way of the freon, so you'll need to discharge and vacuum it again for sure.
    ...
    ....

  3. #3
    Jr. Apprentice
    Join Date
    May 2012
    Location
    Buckholts, Texas
    Posts
    10

    Default

    ok, I took it into town to an ac guy, and the high pressure switch wasn't plugged in, so that's why the compressor wouldn't engage. We evacuated the system and pulled out 1.6oz. Found that the schreider valve on the low side was leaking, so that explains why it kept vacuum with the gauges on it. Put 2 lbs. of refrigerant back in it and now it blows around 40 degrees on recirculating air. yay
    Steve

    ---------- Post added at 04:12 PM ---------- Previous post was at 04:08 PM ----------

    regarding the chirp, I was told since it's a brand new compressor, that chirp will wear itself off within about a 100 miles. No worries.

  4. #4
    Sr. Engineer
    Join Date
    Oct 2010
    Location
    Indianapolis, In
    Posts
    487

    Default

    Thanks for posting back with the details and resolution to your problem. It will keep me on my toes and maybe others as well.
    2000 GMC YUKON SLT, 5.3L tow pkg, G80 rear/w 3.73 gear

  5. #5
    Jr. Mechanic
    Join Date
    Apr 2011
    Location
    Wylie, Texas, United States
    Posts
    103

    Default

    Nuts! I have spent so much time on the AC in my 95 Silverado that I thought I would be able to help! But you got it going already, good for you.
    95 Chevy Silverado
    Beat up by hail and a faulty tow truck
    5.7L V-8
    251,000 miles


Similar Threads

  1. Cold mornings start frustration
    By G.W. in forum Chevy C/K Truck Forum
    Replies: 0
    Last Post: 11-28-2011, 10:33 AM
  2. Avalanche/Silverado PARKING BRAKE FRUSTRATION [Expired Topic]
    By grolman1 in forum Chevy Avalanche Forum (Escalade EXT)
    Replies: 14
    Last Post: 10-06-2009, 08:12 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •