GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default 2011 GMC Sierra 5.3L Oil Pressure Issues at 9,500 miles

    Last August I bought a brand new 2011 GMC Sierra 1500 CC SLE with the 5.3L. Around 4,000 miles I took it in for an oil change at a local place before a 6 hour trip out of state, no big deal. A few months later, I believe closer to 9,000 miles, I took my truck to a dealer for an oil change, I had a card for a free oil change w/ the time to kill. Well not long after their oil change, I noticed my oil pressure gauge was reading out of the norm (i.e 35psi at cold start, right under 40psi accelerating, and at 20psi when stopped with engine warmed up). I contacted the dealership and they said it didnt sound like a problem, but would gladly check it out. Come to find out, my oil pump was weak and their was "trash" in the line. Oil pump, pressure relief valve, and oil all replaced. My truck was brought in because my gauge was out of the norm, and a problem was located. The problem was "fixed" and verified with a mechanical gauge, yet my dash gauge still reads out of the norm. Does anyone else have or had this issue and how was it resolved if so?

    Also when I say norm, I am referring to the dash gauge showing more towards the 40psi mark. I refer to this as the norm because that is what the gauge showed until approximately 9,600 when it dropped and an issue was located.
    My cluster all shows to be working fine, and the repairs were covered under warranty.

  2. #2

    Default

    hmm, dunno what to tell you on that one. could be the sending unit for the gauge itself is bad... is the dealership posative that they fixed the oil pressure issue? are they sure the oil pressure is where its sposed to be and the gauge is just reading low?

    id get that checked along with the sending unit.

    Alex


    2011 GMC Sierra SLE 5.3 Z71 4X4 Stealth Gray Metallic / 2004 Chevy Impala LS 3.8 Cappuccino

    Tow mirrors - Diablew Tuned - Flowmaster Regular 40 - Ready Lift 2.5' lift - BFG LT A/T K/Os - Carr Light Wing - TruckLite LED lights - Optima Red Top - 50% Front Window Tint - Line-X bedliner - Airaid MIT - Tekonsha P2 - ARS Billet Grill - Fia custom fit seat covers

  3. #3

    Default

    I dont think thats your fault bro, I had the same problem, cold start and idle was fine but when I accel, around under 2k rpm it flies to 40. They replaced a few things (They werent clear on what they did, but problem was fixed.) But now i have a constant problem with my gas pedal, it keeps messing up and cutting power to my engine, theyve replaced the whole gas pedal assembly 4 times and every time it fixes the problem for a few months.

    2010 GMC Sierra Texas Edition
    K&N CAI
    Spintech Muffler
    8000k HID Kit (Lows)
    3000k HID Kit (Fogs)
    Custom LEDS
    Denali Punch Grille
    1000W JL Amp.
    Competition 12 JLs
    Alpine DVD/Navi Screen

    Check out My CarDomain!: http://tinyurl.com/88tcb7v


    When everything's coming your way, you're in the wrong lane.


  4. #4

    Default

    Yeah, I brought it back again and the mechanic came speak to me. I asked him why if the problem was fixed my gauge is still off. He shrugged his shoulders...

  5. #5

    Default

    I also bought a gmc sierra 2011 in August of 2011. It is a 4.8 engine. After the second oil change at 10,333 miles my oil gauge is acting differently. It now reads approx. 40psi when cold and once the engine heats up it reads about 35psi at about 1200rpm and drops off to 20psi at a idle of 500rpm. I believe it read 40psi or better before. A tech. from my dealer said the pressure is normal.

Similar Threads

  1. 2011 Silverado with oil pressure issues
    By blk04cobra1 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 21
    Last: 05-24-2014, 02:30 PM
  2. Low oil pressure...then big time oil leak 15 miles later!
    By alchemist1 in forum GM Powertrain
    Replies: 1
    Last: 07-08-2010, 10:33 PM
  3. Oil Pressure and Temp gauge issues
    By rglickman27 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 06-07-2010, 02:37 AM
  4. Oil pressure issues again!!
    By tcook18 in forum GM Powertrain
    Replies: 2
    Last: 03-15-2010, 09:48 PM
  5. Oil Pressure issues on 2000 2500 HD
    By CLMonti in forum GM Powertrain
    Replies: 1
    Last: 02-19-2009, 08:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •