Not quite sure where else to put this, but this item is used Outdoors so here goes. My cousin has a Echo blower (backpack kind), a new one he just bought, it ran fine up until some point this week. He let his father in law borrow it and he said it worked fine for him. Here's what its doing;

It'll start up like normal on choke then as soon as you switch it to run, it'll kill (usually normal). Restarts on run but doesn't stay running unless you switch back and forth between choke and run for a few minutes. Once you have it "warmed up" if you switch it to run, it'll start to bog down and then kill unless you squeeze the throttle all the way and let off very quickly. If you keep doing that, it'll stay running as long as you are squeezing the throttle every second or so. If you hold the throttle down longer than 3 or 4 seconds, it will bog down and kill unless you let off and squeeze and let go like previously mentioned.

If you switch it to choke, you can just squeeze the throttle and hold and it'll run allbeit not as good as it should but it will run and get the job done if that job is less than 20 minutes then it kills but will start back up. Won't idle very good unless you squeeze and let off the throttle a bit.

Took it to the place where it was bought (and still under warranty) and they tried to take it and run "tests" ($60 for a lookover) to see if it was the gas which I know its not because I put gas in it 3 times after emptying and refilling from 3 different stations. Not spark plug as I changed that, airfilter is brand new as well and is not clogged. Ran Seafoam through 2nd and 3rd fills and still runs like crap.

I'm thinking 3 things
1. Its crap
2. Jets may be clogged up with crap
3. May be be getting too much air not enough fuel

Any small engine mechanics out there?