GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default Electrical and Starting issues

    Hi yall. back again. my issue is no lights, no horn, no interior or exterior lights and will not start, only if primed. have checked distributor, changed engine compartment harness,new starter, had alternator tested,changed several other things. Fuel is getting to tbi but not coming out of injectors.

  2. #2

    Default

    Welcome to the club!


    2011 GMC SIERRA CREW CAB 2WD W/5.3

    Convenience Package
    : Adjustable Pedals, Remote Start, Electric Rear Window Defogger, Rear Parking Assist

    Power Tech. Package| Volant CAI| GMC Upgraded Grill| Line-X Premium Bedliner| AVS Smoke Headlight Covers| Demolded| AMI Black Grill Emblem| AMI Black Rear Emblem| EGR In-Channel Window Visors| IPCW Third Brake Light| IPCW LED Fiber Optic Tail Lights| IJDM Dome & License Plate LED's| Flowmaster Exhaust W/ 3" Black Chrome Tips| OEM 20" Rims W/ Goodyear Eagle LS2



    You can't get away from the STORM!














  3. #3

    Default

    We are the Borg. Lift your vehicle and surrender your keys. We will add your biological and technological distinctiveness to our own. Resistance is futile. Erm, I mean ... welcome to GM Truck Club!

  4. #4

    Default

    Welcome to the club Roy, I don't know about the TBI but I'm sure someone on here will be able to help. Good luck and good to have you with us.


    2002 Chevrolet Silverado Extended Cab SportSide: See Mods in My Garage

  5. #5

    Default

    Welcome to the G M T C!


    2010 Z/71 Colorado C/C
    Black 4X4 w/5.3L V8
    ===============
    2007 Winnebago Adventurer
    w/8.1L Chevy & Allison 6spd.
    Canyon Lake, Texas

  6. #6
    Legend


    mfleetwood's Avatar
    Join Date
    Jul 2010
    Location
    Denver, CO
    Posts
    7,213
    Blog Entries
    1

    Default

    I moved your thread to the Tech section of the forum and changed the title to match your question(s)/topic. This should get you more responses.

    Good luck!


    Mike (Denver, CO) - 2008 Sierra 1500 Z71 SLE 5.3L 4WD

    SUSPENSION: Rancho 4" Suspension Lift; Rancho RS9000XL Shocks; Rancho Skid Plates; Rancho MyRide Wireless Shock Controller;
    TIRES:
    BFG All Terrain KO 315/70/17
    DRIVE TRAIN: 4.56 Gears; Detroit TrueTrac Differential; True Cool 40k Transmission Cooler
    PERFORMANCE: DiableSport Predator Tuner; Custom Tuned by Diablew; Magnaflow Exhaust; AFE Cold Air Intake
    ELECTRONICS: Kenwood DNX6180 Touchscreen; Subthump box w/10" Kicker; Driver Information Center (DIC); Rear View Camera
    ACCESSORIES: Westin Brush/Grill Gaurd; Westin Nerf Bars; Truxedo Tonneau; 20% Tint; Tow Mirrors w/Heat & Signals

  7. #7

    Default

    Others here write about a button on the back of the TBI, tocheck functionality. Check your ground wires, and clean with wire brush. Did this happen all at once? There are a few fuseable links in the harness that can cause multiple outages. Year, make and engine in truck? After all that stuff you put on, you still have no lights, horn, or power? Did you check the fuse box? Check for power at the pink wire on the TBI with key on. You say the truck will not start unless primed. Does that mean it dies right away, or does it stay running? Sounds to me like you have a problem with several circuits, and I'm thinking try and add a new ground wire from the cab to the frame, from the engine to the frame, and from the frame to the battery, and see if anything starts working. I would be under the truck checking for cut wires, unless it was in an accident.
    Brian L.




    Brian Larson CST. KC9DAK.
    Janesville WI.
    87 GMC G20 6.2 diesel.

  8. #8

    Default

    thanks rallystx, i will try those things today. if i dont get anywhere with that i will buy a new ecm. 1987 surburban 350 5.7 8 cyl. I had it towed home after it stopped on me about 4-5 blocks from home. I thought at first it was starter. but later found it to be something was draining battery. have not had that issue since the first charge. and changing some things. it dies right away does not stay started, and where would those fuseable links be.

Similar Threads

  1. Electrical Issues
    By horsemanmike in forum GM Electrical Tech
    Replies: 3
    Last: 07-22-2011, 09:44 AM
  2. Electrical Issues
    By Joethepoolguy in forum GM Electrical Tech
    Replies: 7
    Last: 03-21-2010, 09:28 PM
  3. Electrical issues
    By okysmokey911 in forum Chevy C/K Truck Forum
    Replies: 4
    Last: 02-05-2010, 09:51 AM
  4. Electrical Issues
    By ChevyFan in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 10
    Last: 12-03-2008, 08:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •