GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1

    Default Blower motor not working

    I just picked up a 97' Tahoe and no action out of blower so I tested the two wires. Nothing from the hightest setting, but the lower settings all read 12v about ,so I pulled the motor ,tested it runs good so the 12v. I read won't even lite a small bulb The switch ? Any ideas Thanks, Steve

  2. #2
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,390

    Default

    Blower motor resister, they are usually the culpret. Its hardend wires, it is usually bolted to the truck with a screw or 2, if the hardened wires are rusted or corroded then that could be the problem, they are around 20 bucks to replace.
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  3. #3

    Default

    blower motor resistor

    2009 Chevrolet Silverado 1500 LT Z71 Crew Cab "All-Star Edition"

    Line-X'd Bed
    Line-X'd Custom Brush Guard(Heavy Duty)
    5.3L Flex Fuel
    275/65R18 Toyo Open Country AT2's
    2" Rough Country Leveling Kit(want to get the 2.5 RC kit)
    EGR In-Channel Vent Visors
    Exterior PLUS Package
    Interior PLUS Package
    K&N Drop-In Air Filter
    ProFlaps
    Cat-Back Dual Exhaust
    Black Bowties
    Diablo Sport Predator(AFM Disabled)
    ProFlaps
    Towing Mirrors
    Next Planned Mods
    Blacked out Tail Lights
    Aftermarket Rims

  4. #4

    Default replaced the resister, still nothing

    Ok , So I pull the resister (what a pain) looked ok but I went and got a new one and still no action from blower. Do the speed control switchs ever fail ? Any thoughts? Thanks, Steve

  5. #5

    Default

    the fan switch does go bad.

  6. #6

    Default

    Ok, So I pulled the switch and that was it. If you look real close at the terminals the plastic is a little melted next them, $39 bucks to the dealer and it's good to go . Thanks, Steve

  7. #7

    Default

    I replaced my resistor a few months ago, and the replacement has failed already. The cuicuit board on the resistor had a burn mark on it like the last one. What should I look for now.

  8. #8

    Default

    the blower motor may be pulling to many amps

  9. #9

    Default

    How do I fix that?

Similar Threads

  1. Airbag light, blower not working on any speed
    By deepstuff in forum Chevy C/K Truck Forum
    Replies: 5
    Last: 12-27-2011, 09:47 AM
  2. Blower motor not working
    By lancer in forum General Chevy & GM Tech Questions
    Replies: 8
    Last: 06-28-2010, 05:18 PM
  3. 2003 silverado blower fan not working
    By yochanan in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last: 01-30-2010, 07:01 PM
  4. Blower stopped working
    By engrsjp1 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 09-25-2009, 02:00 PM
  5. air/heat blower not working?
    By gabronco91 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 7
    Last: 12-14-2008, 01:13 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •