GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default Changed my TPS and...

    new to the site, have a 91 silverado 5.7 2wd, anyways heres my issue, i was driving the other day and when i was just coasting the check engine light came on, and when i started to accelerate the light would go off, so i got home and pulled the codes, 12 like always and 22 (TPS), and ive have a high idle issue also (i thought it might be since i just move to albuquerque, nm the altitude might have had something to do with the idle idk) so i figured id change the tps sensor and see what happened since it was a cheap part, i changed it out and now it shifts hard into gear and takes forever to change from first to second and when it does it slams into gear, so i thought i might have gotten a bad tps, so i put the old one on same deal, took the new one back and exchanged it for another and still same issue, i also disconnected the battery for half an hour and same thing, im at a loss, cant figure out what happened from just changing out the tps, dvom readings for the tps are 5.043 on the grey wire, .802 on the blue wire at idle and 3.280 at wot, any info would be greatly appreciated, thanks D.J.
    Last edited by d_stang_j; 06-26-2012 at 10:56 AM.

  2. #2

    Default

    messed with it all day, went to junkyard and pull and ecm and changed out, no change...im at a loss....

  3. #3

    Default

    did you ever get it figured out.

  4. #4

    Default

    Quote Originally Posted by Josh View Post
    did you ever get it figured out.
    yeah turned out that the tv cable or kickdown cable (cable from trans to tb) had came out of the bracket it snaps into cause one of the two clips that hold it in the steel bracket had broken off at one time or another and it was sitting behind the bracket adding just about another half inch or so to the length causing long and hard shifts, put it back in bracket and put a zip tie on the front side til i find another (or might just leave it alone) and it works and runs like a champ

Similar Threads

  1. Changed them all!
    By krp2nite in forum Maintenance & Upkeep
    Replies: 9
    Last Post: 09-12-2012, 05:25 AM
  2. Ok....changed my dash...again...
    By sstoner911 in forum Chevy Truck Accessories
    Replies: 16
    Last Post: 10-26-2011, 09:41 PM
  3. What fluids need to be changed?
    By ZSI52 in forum GM Powertrain
    Replies: 13
    Last Post: 03-10-2010, 06:44 PM
  4. Do you think they have changed much?
    By dwill3015 in forum The Coffee Shop ~ Chit Chat
    Replies: 2
    Last Post: 12-12-2007, 08:23 AM
  5. 2x4 changed to 4x4?
    By trenchwarfare in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last Post: 11-01-2007, 10:35 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •