GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 17
  1. #1

    Default 4.3l engine data and help on diagnosis.

    Hi,
    I am new to the forum and have a specific problem with my truck that I have been working on for months. Here is the vehicle description, problem description, data, and parts that have been replaced.

    Vehicle: 2000 Silverado 1500, 4.3l v6, 190k miles


    Problem description: Starts and idles fine, but stumbles for about 5-10 seconds after I give it gas. As soon as it recovers, the truck runs fine. Occurs when engine is hot or cold. Throwing codes 171 and 174(lean fuel banks 1 and 2). Getting about 16MPG, expecting to get 20mpg.


    Data: I have a OBDII to USB interface and OBDWiz software on a laptop that collect live data. Here are the reports:


    Service $02 - Freeze Frame Report (when code is thrown)
    Date: 6/27/2012 1:19:52 PM
    PID Description Value Units
    0x02 Freeze frame DTC P0171
    0x03 Fuel system status Closed-loop, using oxygen sensor feedback to determine fuel mix
    0x04 Calculated load value 23.92 %
    0x05 Engine coolant temperature 188.6 F
    0x06 Short term fuel % trim - Bank 1 15.62 %
    0x07 Long term fuel % trim - Bank 1 23.44 %
    0x08 Short term fuel % trim - Bank 2 20.31 %
    0x09 Long term fuel % trim - Bank 2 23.44 %
    0x0B Intake manifold absolute pressure 12.47 PSI
    0x0C Engine RPM 1582.5 RPM
    0x0D Vehicle speed 54.68 MPH
    0x10 Mass air flow rate 5.17 lb/min
    0x11 Absolute throttle position 36.08 %







    Click image for larger version. 

Name:	o2_2.jpg 
Views:	157 
Size:	76.3 KB 
ID:	41105
    Click image for larger version. 

Name:	stft_2.jpg 
Views:	145 
Size:	64.8 KB 
ID:	41106
    Click image for larger version. 

Name:	MAP_TP_2.jpg 
Views:	146 
Size:	60.3 KB 
ID:	41107
    Click image for larger version. 

Name:	stats2.jpg 
Views:	150 
Size:	59.5 KB 
ID:	41108





    The above charts(except the Freeze Frame) show a trip through to to corner store about 2 mile away(on a hwy) with the engine already warm. Each chart is synced with time and the stats are for this same trip. The Short Term Fuel Trim(STFT) mean is above 10, which causes the 171 and 174 codes. However, O2 sensor mean volt is .5 and .4, which I believe good. Thus, I do not think there is actually a lean condition here. Thus I am stumps to what is causing the codes and presumably, the stumbling.



    Parts replaced:
    Upper and lower intake manifold gaskets(which were obviously blown and leaking coolant)
    EGR valve
    Map sensor
    O2 sensors(before the cat, ones after cat were replaces no to long ago)
    MAF sensor
    Throttle position sensor
    fuel filter
    Fuel pump(including sock filter)
    Cleaned injectors(took the spider out and cleaned)
    Cleaned entire intake and throttle body.


    I have checked for vacuum leaks extensively by spraying card cleaner around the engine and cannot get the rpms to budge or the O2 sensor data to show any deviation.


    I was thinking a possibility is that both cats are clogged. The coolant leak was going into cycliders and out the exhaust. However, I would expect data to indicate this. The freeze Fame data for when the codes are thrown shows 12.47psi at 54mph.


    I am running out of ideas. Any help would be appreciated.


    Randy

  2. #2
    Sr. Engineer
    Join Date
    Oct 2010
    Location
    Indianapolis, In
    Posts
    493

    Default

    If you can, monitor the fuel pressure while this occurs, it may be an issue with the pressure regulator not responding quick enough and starving for fuel.
    2000 GMC YUKON SLT, 5.3L tow pkg, G80 rear/w 3.73 gear

  3. #3

    Default

    dpeter,
    Thank you for your reply. I cannot monitor fuel pressure except with a gauge to the service port on the fuel line as it goes into the injectors(the "spider"). I can monitor fuel rate from the OBDWhiz. I'll do a test run tomorrow and post the results. However, If is was fuel delivery, I would expect it to failure under a heavier demand for fuel than 5mph. That is, after the stumbing occures and passes, then I can drive the vehicle just fine...excpet that it throws codes and get poor gas milage.

    I did repalce the fuel pressure regulator about 8 months ago when I was having a different problem. There was enough current to cause the bulb on my sparkplug tester to light up, but not enough to casue a spark. I spent a whole bunch of time and parts tracking down what I though was fuel problem until I opened the distributor cap to find a shorted rotor. Thus, the fuel pressure reg has been swaped. Also at the time, I measured the fuel pressure on my old pump at 60psi, which is the low end of the acceptable range. Thus, I swapped the fuel pump, but I should get the gauge and measure it just to make sure.

    Randy

  4. #4
    Sr. Engineer
    Join Date
    Oct 2010
    Location
    Indianapolis, In
    Posts
    493

    Default

    I would agree about fuel delivery under heavy load but my thoughts were more about a momentary lack of fuel then recover to correct levels. From what you have done so far , I would not expect to see fuel issues but it's best to eliminate it and move on from there. So this stumble is just "off idle" and accellerating?

  5. #5

    Default

    yes, The stumble only happenes after I start the engine and press the gas pedal. After stumbling for 5-15 seconds, the truck runs "fine", but gets poor gas milage and seems bogged down a bit. The stumbling will occure regardless of engine temp when started.
    The ODB Whiz software listed a "fuel rate" but I found it to be only a scaling of the MAF(see charts). I did not get to the parts store to get a fuel pressure gauge today. Since I cannot read fuel pressure going down the road, I will have to settle for reving it up in the garage to see if pressure drops below 60ppsi. I will let you know how it come out when I get the gauge.

    Here are more charts. I added some parameters. I was trying to analyze the MAP reading. It seems to max out at even a 50% throttle position. However, I admit that I am not sure what to expect as I have nothing to compare.
    Again, any help in intrpreting these would be much apreaciated.
    Click image for larger version. 

Name:	maf_3.jpg 
Views:	127 
Size:	64.0 KB 
ID:	41158Click image for larger version. 

Name:	mph_time_3.jpg 
Views:	129 
Size:	65.7 KB 
ID:	41159Click image for larger version. 

Name:	map_tp_3.jpg 
Views:	130 
Size:	66.3 KB 
ID:	41160Click image for larger version. 

Name:	stft_3.jpg 
Views:	130 
Size:	67.3 KB 
ID:	41161Click image for larger version. 

Name:	o2_3.jpg 
Views:	131 
Size:	72.8 KB 
ID:	41162

  6. #6
    Sr. Engineer
    Join Date
    Oct 2010
    Location
    Indianapolis, In
    Posts
    493

    Default

    I just love data. Can you change the sample rate? I see they are all about a 25 minute picture, can you get it down to a minutes worth and be able to better see what is happening durring the stumbling period?

  7. #7

    Default

    Good suggestion. I can reduce the chart time to 1 minute and try and capture the stumbling. I am going down to the garage now and will try it.

  8. #8

    Default

    I went down to the garage and captured a 1 minute chart of the stumbling with the engined reved after a start. Then, before comming back to post the results, I performed another test that was suggested to me. I unplugged the MAF and the truck ran perfect. Below are the charts from a short drive with the MAF unplugged. Short Term Fuel Trim in within bounds(+-10) and the O2 reads good. This is a brand new MAF that I am supposed to belive is not only bad, but bad in the same way as my old MAF. Not sure what to think, but I guess I'm off to the parts store for a new one tomorrw.





  9. #9

    Default

    Just FYI, here are the one minite charts for the stumble(with "bad" MAF plugged in).
    revs 2,3, and 4 stumbled. The rest did not. Notice that the STFT kicks in on rev 5 through 7. I guess I don't really know what the MAF should read like.
    Click image for larger version. 

Name:	maf_4.jpg 
Views:	129 
Size:	56.1 KB 
ID:	41205Click image for larger version. 

Name:	speed_time_4.jpg 
Views:	126 
Size:	53.9 KB 
ID:	41206Click image for larger version. 

Name:	map_tp_4.jpg 
Views:	130 
Size:	56.6 KB 
ID:	41207Click image for larger version. 

Name:	stft.jpg 
Views:	124 
Size:	54.5 KB 
ID:	41208Click image for larger version. 

Name:	o2_4.jpg 
Views:	127 
Size:	56.6 KB 
ID:	41209

  10. #10

    Default

    I got a fuel pressure gauge from autozone and measured the fuel pressure. Its 50psi at idle and shoots up to 67 when I rev it. If memory serves me correct, 50-60 is the proper range for this engine. So, I'm on the lower end.
    I got a new MAF and am going for a test drive now.

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. Diagnosis booster, MC or both
    By T-bone in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last: 07-01-2012, 01:46 PM
  2. Power window diagnosis help
    By alchemist1 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last: 11-07-2011, 05:50 PM
  3. Fuel pump diagnosis...
    By alchemist1 in forum GM Powertrain
    Replies: 2
    Last: 10-05-2009, 07:49 PM
  4. 1990 Suburban Won't Start, Need Diagnosis
    By 1990Suburban in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 08-31-2009, 01:02 PM
  5. Rough Idle-EGR Diagnosis '94 suburban
    By 94VERTiGO in forum GM Powertrain
    Replies: 1
    Last: 06-07-2008, 08:27 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •