GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default Coolant temp gauge not working on 99 K3500

    I finally got around to starting the 5.9 with all the wiring hooked up. Every gauge worked as it should, except the coolant temperature. It rests to the left (key off) and moves up to 160 (lowest #) when the key is on. I grounded out the yellow sensor wire and the gauge doesn't move at all. Hooked a scan tool up and the computer knows how how hot the engine is, but it will not send the info to the gauge to display it.

    Any ideas?? I can move the gauge by grounding out the sensor pin on the back of the gauge, but still stays on 160 when released. Hope everybody has their thinkning caps on...

    Thanks in advance!!
    1999 Chevy K3500 5.9 Cummins transplant with NV4500/NP205. Dana 60 SAS/Dana 80 DRW. Bendix Tu-flo 501 compressor with AD-9 air dryer. Jacobs exhaust brake and air pinion brake. Dual Taurus electric fans.

  2. #2
    Sr. Mechanic ChevyHD's Avatar
    Join Date
    Jan 2011
    Location
    Elberon, Iowa, United States
    Posts
    179

    Default

    Ok, so your sensor is reading the right temp but your gauge cluster isn't displaying it correctly...I would replace your stepper motors and go from there.
    Adam
    2004.5 CCSB Duramax
    Max Effort Tuning by Idaho Rob - Goerend Transmission - PCV ReRoute - EGR Blocked - Plugged Resonator - 5" Diamond Eye Turbo Back - Tie Rod Sleeves - All On Mod - Edge Insight CTS - Recon Taillights, Cab Lights, & 3rd Brake Light

  3. #3

    Default

    What he said ^



    If at first you don't succeed, chances are, you are using too small of a cheater bar

    Current:
    1999 GMC Sierra SLT Z71 | 5.3 Vortec | Spectre Cold Air Intake | TransDapt TBS | Hypertech 30005 Tune | 2005 Chevy Tails | Denali headlights | AWS Bug Shield | 265/75/16 Mastercraft Courser A/T | "Ghetto" painted tailgate | Boss HD Speakers | 2005 Overhead Console | Dual Thrush Turbo Mufflers
    Future:
    Bigger Amp Alternator | Electric Fans | Oil/Trans Fluid cooler | Re-done exhaust | Paint | Interior Restoration/upgrade with newer model stuff | Window Visors (In channel) | Tint | Low-Profile Tool Box | LEDs throughout stock cab locations | And whatever is spurr of the moment
    US Navy Sailor :sign0011:

  4. #4

    Default

    Anyone know where to get them? It is an OBS truck and the only stepper motors I can find are for the newer style gauges.
    1999 Chevy K3500 5.9 Cummins transplant with NV4500/NP205. Dana 60 SAS/Dana 80 DRW. Bendix Tu-flo 501 compressor with AD-9 air dryer. Jacobs exhaust brake and air pinion brake. Dual Taurus electric fans.

Similar Threads

  1. Temp Gauge not working properly
    By Jeff Brown in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 10
    Last Post: 01-07-2014, 07:11 AM
  2. Temp Gauge Not working Properly ~ 2005 Silverado 1500
    By biglinc1 in forum General Chevy & GM Tech Questions
    Replies: 16
    Last Post: 10-15-2013, 11:09 PM
  3. coolant temp sensor
    By engineerbrian in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 07-15-2010, 04:06 PM
  4. Coolant Temp Sensor
    By Googenheimer in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 02-22-2010, 11:50 AM
  5. 2003 z71 5.3L Coolant Temp Gauge Trouble
    By gaborn73 in forum GM Powertrain
    Replies: 8
    Last Post: 01-12-2010, 11:55 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •