GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default OBD-II port dead, Check engine light on, Truck runs fine.

    It is a 2004 Chevrolet Silverado Z71 5.3L V8 4WD. I need to know which fuses (fuse ID number and location) being blown might allow the truck to run, but that would kill the OBD-II data port signals?

    Recent dealer inspection says it needs a new O2 sensor, but we can not get an OBD-II signal at the port. I suspect a fuse, or fuses are blown (had the same problem recently with the Saturn, and it was a blown PCM-B fuse in the PDC under the hood, 2001). Need some help. I am new to this beast. But not new to diagnostics....

  2. #2

    Default

    Forgot to mention, the check engine light is on, and everything else seems to work!

  3. #3

    Default

    I see you responded in the thread where someone else had a similar problem.
    http://www.gmtruckclub.com/forum/sho...#axzz1ztVKJTC8

    I don't have a set of manuals for your truck; but, I agree, with you, it is probably a fuse.

    So................what happens when you check all of the probable fuses?
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  4. #4

    Default

    Well, I don't have the truck here, but just got a call that the cigarette lighter fuse, 15 amp is bad. I won't know till tomorrow if it fixed the OBD-II, or if there are more fuses in the path to find? I am wondering if the O2 sensor issue is related. I told him to check the sensor and wiring for any off road carnage.

  5. #5

    Default

    i had a dead OBD-II in my 05 sierra. was the 15 amp cigarette lighter fuze that caused the issue. should be no other fuzes to worry about. kinda one of the weird things GM did.

    swapped fuzes out with a good fuze and away i went.

    Alex


    2011 GMC Sierra SLE 5.3 Z71 4X4 Stealth Gray Metallic / 2004 Chevy Impala LS 3.8 Cappuccino

    Tow mirrors - Diablew Tuned - Flowmaster Regular 40 - Ready Lift 2.5' lift - BFG LT A/T K/Os - Carr Light Wing - TruckLite LED lights - Optima Red Top - 50% Front Window Tint - Line-X bedliner - Airaid MIT - Tekonsha P2 - ARS Billet Grill - Fia custom fit seat covers

  6. #6

    Default

    Quote Originally Posted by ecomike View Post
    Well, I don't have the truck here, but just got a call that the cigarette lighter fuse, 15 amp is bad.
    That's it Mike, someone just overloaded the power outlet.

Similar Threads

  1. 92 s10 runs fine then stalls
    By loosehead in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 11-27-2011, 07:52 AM
  2. Service light v.s check engine light
    By redbone in forum Chevy C/K Truck Forum
    Replies: 1
    Last: 07-21-2011, 11:04 AM
  3. 99 GMC Suburban 260000miles Stubbles on accel.runs fine after engine heats up
    By dirt2191 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 08-10-2010, 02:40 PM
  4. Check Engine Light
    By Nevada Born in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 10
    Last: 12-27-2008, 01:18 AM
  5. 99 5.3L check engine light
    By ss_silverado_phoneix99325 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 3
    Last: 10-03-2007, 05:31 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •