GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default Plugged a Bad EGR. What can this cause.

    i plugged a bad egr because it was causing my stalling. i plugged it and the ol 350 tbi runs like a dream. But being theres a code lit for a egr code. what can this code cause. mpg change,timing change,power loss etc. i plan on putting a new one on soon though. but will it harm my 230k tbi. it runs so well for its age.

  2. #2
    Sr. Engineer
    Join Date
    Oct 2010
    Location
    Indianapolis, In
    Posts
    487

    Default

    The computer looks for a change in RPMs when it cycles the EGR and if it does not see it for a number of times it will set a code for an egr malfunction. As far as changing how it operates the engine: I believe it will make no differencein the items you are asking about,. I made a plate to eliminate mine and had no problems and also plugged the exhaust and removed all traces of the EGR.
    2000 GMC YUKON SLT, 5.3L tow pkg, G80 rear/w 3.73 gear

  3. #3

    Default

    i have read of people using plates to block them off. so basically it just makes a code then? ive had the egr malfunction code on since i unplugged vac line and capped it off. i just was making sure im not going to carbon up the intake from not having a egr to evacuate properly. ill replace when it gets cooler out. 105 here.

  4. #4
    Jr. Mechanic LoneWolf'burban's Avatar
    Join Date
    Apr 2010
    Location
    Ozarks
    Posts
    112
    Blog Entries
    1

    Default

    Josh, what's the specs on the truck you did this to?
    1992 GMC Sonoma GT 4.3
    1984 C20 'burban 454
    1963 C10 283
    One lead foot
    Two hands that turn a steering wheel very quickly and very well.

  5. #5

    Default

    Well its a stock 350 tbi. Its a 94 z71. Has 4l60e. Engine is 231k now still runs like it was new starts at the bump of a key. Holds a good 45 psi of oil pressure. I run a 170 deg. Thermostat. Aswell. I like my engines cool and I use 10w-30 conventional valvoline always with a wix filter. Engines quiet as a mouse. Egr still plugged. It had a vac leak coming off accel. Not a problem since. I also change oil around the 2500 mile interval. My way of seeing things is change oil before its dirty. Then your engine wont ever GET dirty. I must be doin something right

  6. #6
    Sr. Apprentice
    Join Date
    Jun 2013
    Location
    1391 N Jefferson St., Anaheim CA 92807
    Posts
    65

    Default

    Main cause of EGR valve bad is buildup of carbon, soot and other deposits and heat, which causes metal like springs to break or lose strength.

Similar Threads

  1. Plugged Cat???
    By SGSelby in forum Chevy C/K Truck Forum
    Replies: 3
    Last Post: 01-30-2012, 01:23 PM
  2. Replies: 0
    Last Post: 09-24-2010, 12:00 PM
  3. Are You Plugged In? - Wall Street Journal
    By Steve in forum Chevy Volt Forum
    Replies: 1
    Last Post: 02-21-2010, 06:20 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •