GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 10

Thread: Brake issues

Hybrid View

  1. #1

    Default Brake issues

    Hey all, I have an issue I hope some of you can shed some light on...

    A friend of mine has a 96 Chevy K2500 Suburban with the 7.4 in it. Recently the brakes have peen presenting serious issues where the pedal is next to impossible to push and he has to almost stand on the pedal to get it to stop. He already replaced the hydro booster and that seemed to fix it but after a day or two the issue returned.

    Can anyone suggest what to do next?

    Thanks

  2. #2

    Default

    Quote Originally Posted by khurrle View Post
    Hey all, I have an issue I hope some of you can shed some light on...

    A friend of mine has a 96 Chevy K2500 Suburban with the 7.4 in it. Recently the brakes have peen presenting serious issues where the pedal is next to impossible to push and he has to almost stand on the pedal to get it to stop. He already replaced the hydro booster and that seemed to fix it but after a day or two the issue returned.

    Can anyone suggest what to do next?

    Thanks
    The truck may have issues with the vacuum assist. Get a vacuum gauge and measure how much vaccum you are getting at the vacuum line from the intake manifold to the brake booster. If you have a vacuum pump, remove the hose from the booster fitting, connect a hose to a vacuum pump and pull a vacuum to the brake booster and step on the brake pedal and see if the pedal effort improves.
    2011 Chevy Silverado LT 4WD 30k miles
    2001 Suburban 2WD, 5.3, V8 185k miles
    1993 964
    1996 318TI

  3. #3

    Default

    Quote Originally Posted by bazar01 View Post
    The truck may have issues with the vacuum assist. Get a vacuum gauge and measure how much vaccum you are getting at the vacuum line from the intake manifold to the brake booster. If you have a vacuum pump, remove the hose from the booster fitting, connect a hose to a vacuum pump and pull a vacuum to the brake booster and step on the brake pedal and see if the pedal effort improves.
    All good suggestions; but first, just inspect the vacuum line, it may be plugged.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  4. #4

    Default

    Thanks for the replies , but his booster is not vacuum operated, it is hydraulic.

  5. #5

    Default

    Quote Originally Posted by khurrle View Post
    Thanks for the replies , but his booster is not vacuum operated, it is hydraulic.
    Well, there's your problem, hahaha.

    You could be right; however, it is my understanding, that the 7.4 liter engine is a gas engine displacing 454 cubic inches.

    If it is a gas engine, you have "power" brakes. Power brakes are vacuum over hydraulic. If the pedal is hard to push, most likely the vacuum assist (the power part) is not working.

  6. #6

    Default

    So it is both hydraulic and vacuum then? Yes he has the 454 gas engine in it, I know that he first replaced the brake hydrobooster which instead of being the big round vacuum guy like mine was a hydraulic mechanism. from there he will need to inspect the vacuum lines below, is that right?

  7. #7

    Default

    Quote Originally Posted by khurrle View Post
    Thanks for the replies , but , is booster is not vacuum operated, it is hydraulic.
    My bad, for wrong info.

    Power steering pump as stated by RayVoy. could be suspect. Power steering pump supplies brake assist instead of vacuum from regular vacuum assisted booster.

Similar Threads

  1. ABS Brake issues with 99 suburban
    By royiii01 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last: 06-18-2012, 05:35 PM
  2. Brake Issues
    By chvyfun in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 04-25-2012, 06:57 PM
  3. Brake issues on 99 Suburban
    By Mack46 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 11-24-2011, 10:02 AM
  4. 05 sub having parking brake issues
    By whymeintrouble in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last: 07-13-2010, 04:29 PM
  5. GMT 900 Brake issues?
    By lgrppup in forum Lifted & Offroad Suspension
    Replies: 1
    Last: 08-01-2009, 09:51 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •