GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default Stabiltrak system

    Hi everyone Im new to the site and was wondering if anyone could help me out. I have a 2008 Chevy Tahoe that i recently put a 6" lift kit on. On the description of the kit it stated that certain maneuvers would cause stabiltrak light to come on. Sure enough when making hard left n right hand turns the stabiltrak light would flash a couple of times then go away. Last week I was turning and the Light came on and never went away. Also it says service stabiltrak, stabiltrak off and service traction control. The dealership says its my oversized wheels but i doubt it. Any Help???? Thanx

  2. #2

    Default

    I note that it's not just a lift you've got, but oversized wheels/tires?

    Since the problem only manifests while driving it's likely not a bad wheel sensor, but you might check them all to make sure none of the wires are pinched, rubbed raw, etc. Next, look at alignment and make sure it's good. (In theory you did an alighment after the lift, right?) If all is well on that front then use a handheld programmer to adjust the speedo properly for your oversized wheels/tires; I've read that the NNBS vehicles with traction control really don't like it when they sense that the wheels/tires are going faster/slower than it thinks they should be based on the transmission output.

    That's the limit of my knowledge on the subject. Perhaps others can shed more light.
    Last edited by SurrealOne; 07-13-2012 at 12:57 PM.

  3. #3

    Default

    Quote Originally Posted by SurrealOne View Post
    I've read that the NNBS vehicles with traction control really don't like it when they sense that the wheels/tires are going faster/slower than it thinks they should be based on the transmission output.
    Yea I was playing around at work with my 2011 in a wet and slick 6acre empty parkinglot a few months back just throwing the truck into curves and letting it slide around when my Stabilitrac light started going crazy, it wouldnt go off even after cycling the ignition key a couple times so I brought it to the dealer and played dumb to get them to shoot the codes and find out the problem under warranty, they told me sometimes if you get to many traction hits in a short amount of time it'll overwhelm the computer and basically it needs to be rebooted by using a programmer, they also said next time it's real slick out turn off the stabilitrac to stop this from happening if your in ice or extremely slick conditions where Stabilitrac isnt gonna help anyways.
    But I dont think the 07's had an on/off switch for Stabilitrac.

  4. #4

    Default

    I did align the truck with the stock wheels after the lift but when i put on the big wheels i did not. Could this play a part?? Maybe i should do it again because the wheels raised the truck a couple more inches. My truck is at a different dealership now I'm waiting to hear the results from the codes.

  5. #5

    Default

    Different diameter tires also change the number of rotations made across a given distance. You DID correct for this using a handheld tuner, yes? If not, use the calculator, here, to determine the speedo error you've introduced with your larger diameter tires: http://www.miata.net/garage/tirecalc.html ... and understand that you need to correct for it.

    Again, I've read that if the truck thinks the wheels are moving at one speed (based on the wheel speed sensors) and the tranny is telling it something that causes it to see tranny speed != wheel speed ... then you have an ugly situation as far as stabilitrak tends to go. Someone who has been through this might want to confirm, but if no one here has, I know you can search Google to get some corroboration...

  6. #6

    Default

    Yeah they told me it was a "HISTORY" code. I had it rebooted as u suggested and it seems fine. I did not have the speedometer re programmed yet but that will b next on the list come Monday morning!! Thanx guys!!!

Similar Threads

  1. System Build Log ~ Sound System
    By mudpuppy in forum Chevy Truck Talk & News
    Replies: 17
    Last Post: 01-01-2012, 07:16 PM
  2. What is up with my A/C System?
    By JRD761 in forum General Chevy & GM Tech Questions
    Replies: 6
    Last Post: 09-22-2011, 02:02 PM
  3. New system
    By taxidriver20 in forum Audio, Video & Gadget Tech
    Replies: 4
    Last Post: 03-07-2011, 09:48 PM
  4. sub system for reg cab
    By kylegillean in forum Audio, Video & Gadget Tech
    Replies: 4
    Last Post: 07-10-2009, 10:37 PM
  5. Stabiltrak problem
    By dveenhuis in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 06-18-2008, 01:05 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •