GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Question Knocking and Pinging on acceleration -horrible in four wheel drive?

    I have a 1995 GMC 2500 4x4 with 5.7L Automatic (60 series). Knocking and pinging on acceleration is driving me nuts. If I am in four wheel drive I have to keep it in second gear it is so bad. To date I have replaced the spark plugs, plug wires, distributer cap and rotor, distrubuter, ignition coil, air filter, fuel filter. I recently replaced the PCM which eliminated a check engine light that has been on for five years. The distibutor, spark plugs, plug wires, dist cap and rotor have around 30000 miles on them. Everything else has been done in the last year. Ohterwise the truck runs fine. Any ideas would be helpfull. I am also looking for stock rims for the same truck - six bolt sixteen inch rims. halbey

  2. #2

    Default

    Well, it sounds like carbon build-up on the piston tops. There are a number of produces that claim success removing this type of deposit.

    You should have a knock sensor, that should retard the engine timing to compensate for the knock, perhaps yours does not work.

    Why, and where, are you driving in 4wd?

    Try using higher octane gas.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3

    Default

    Interesting! Wouldn't the knock sensor produce a trouble code if it were not working correctly? I am driving it in snow in Alaska and winter is coming soon! Higher Octane fuel is not an option here. Anyway to actually determine if I am getting the build up on the piston tops?

    Halbey

  4. #4

    Default

    Quote Originally Posted by halbey View Post
    Interesting! Wouldn't the knock sensor produce a trouble code if it were not working correctly? I am driving it in snow in Alaska and winter is coming soon! Higher Octane fuel is not an option here. Anyway to actually determine if I am getting the build up on the piston tops?

    Halbey
    Sure sounds like you're simply igniting at the wrong time. I'd recommend pulling the codes. I've a handheld device, and my buddy down the street was having a similar problem. He kept saying "There's no trouble light!" I put the device on anyway, and low and behold... the first code that popped up showed his check engine light sensor wasn't operational. (Blown fuse). He had 4 codes on the thing.

    Check it anyway. That's my motto.

    You might very well have a sensor out. Definitely sounds like you've got timing problems, and your computer may not be able to compensate for the octane level you're putting in. At the very least, you can buy octane booster, and put a bottle in to eliminate it at fill up. A bit pricier, but it'll get the job done, and you can totally carry them and not have to worry about octane at the stations.

    Skippy
    2006 Vortec Max 1500
    Performance:
    -Custom Tune (389HP 440 Ft/lbs Trq - Dyno'd) | Volant CAI | Magnaflow Dual-in/out Exhaust w/3" stainless pipe tips | Fully Built Transmission w/ Red Eagle Clutches & Kolene Steels w/ Corvette Servos and Stage2 Shift Kit | 35K Tranny Cooler | Mobil 1 | Royal Purple Rear Diff
    Other:
    -Spray-in Bed Liner
    -Premium Sound w/lifetime Satellite Radio | Leather | Sunroof | Heated Seats
    -Limbstriping from USING the truck (those are badges of honor)

  5. #5

    Default

    Check your base timing. It should be set at 0*. Also check the slop in your timing chain by taking the distributor cap off and watching the rotor button while using a wrench on the balancer to move the engine back and forth. How many miles does the engine have on it?

    The ECM can only adjust the timing so much. If there is a problem outside if it's ability, it will ping and not set a code.
    "It went together didn't it? Well then there has to be a way to take it apart!" - Me.

    Check out my image gallery HERE.



    "The true measure of a man is how he treats someone who can do him absolutely no good." ~Samuel Johnson (1709-1784)

  6. #6

    Default

    I checked the Trouble Codes and got 42 (Ignition Control) but the check engine light is not going on?

    - - - Updated - - -

    I checked Trouble Codes and got 42 (Ignition Control) but the Check Engine Light has not been on? How much play is tolerable at the rotor button? The engine has 173000 miles. The Timing is set at 0%.

  7. #7

    Default

    Quote Originally Posted by halbey View Post
    I checked the Trouble Codes and got 42 (Ignition Control) but the check engine light is not going on?

    - - - Updated - - -

    I checked Trouble Codes and got 42 (Ignition Control) but the Check Engine Light has not been on? How much play is tolerable at the rotor button? The engine has 173000 miles. The Timing is set at 0%.
    Ideally, none. If you have 1* of play, then your timing cannot be set dead on and there will always be a variance. 3 or 4* of play will certainly cause it to run like crap and start pinging and bucking in some circumstances.

Similar Threads

  1. converting 2 whel drive to 4 wheel drive
    By jdaugherty3 in forum GM Powertrain
    Replies: 15
    Last: 11-24-2013, 07:15 AM
  2. 01 Silverado Pinging and Sticking Acceleration Occasionally
    By OE812 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 4
    Last: 10-22-2010, 06:41 AM
  3. Knocking in steering wheel when turning
    By rrod7390 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 15
    Last: 10-08-2010, 02:50 AM
  4. Knocking and pinging
    By twotone guy in forum GM Powertrain
    Replies: 5
    Last: 08-08-2010, 09:02 AM
  5. Weird knocking in steering wheel
    By rrod7390 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 07-04-2010, 12:18 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •