GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default '99 Suburban A/C Too Cold

    So here's the deal...my '99 Sub has developed the problem of the A/C running too cold and freezing up the evaporator.The specs call for the clutch cycle switch to shut off the compressor at 25 lbs-low side, and turn it back on at 45 lbs. With a static pressure of 120 lbs, ambient air temp of 85 degrees, engine idle 1200 RPM: when the system is turned on the compressor activates and the low side pressure stabilizes at around 30-34 lbs...the high side sits at around 180-200 lbs...fan on high, max setting on temp control, the middle-front register reads 28-36 degrees. This is great for awhile until the evap freezes up and airflow is restricted. The lowside pressure will not drop down to 25 lbs to activate the switch to shut off the compressor. I even installed a new pressure cycle switch to no avail since the pressure will not drop enough to activate it anyway. So every half hour or so, I have to manually shut off the compressor at the control panel for about 5 minutes, and then start the process over again. The rear unit is controlled by the TXV and continues to function just fine (rear register temp 36-40 degrees). Any ideas on this? Thanks.

  2. #2

    Default

    Quote Originally Posted by beltrunner View Post
    So here's the deal...my '99 Sub has developed the problem of the A/C running too cold and freezing up the evaporator.The specs call for the clutch cycle switch to shut off the compressor at 25 lbs-low side, and turn it back on at 45 lbs. With a static pressure of 120 lbs, ambient air temp of 85 degrees, engine idle 1200 RPM: when the system is turned on the compressor activates and the low side pressure stabilizes at around 30-34 lbs...the high side sits at around 180-200 lbs...fan on high, max setting on temp control, the middle-front register reads 28-36 degrees. This is great for awhile until the evap freezes up and airflow is restricted. The lowside pressure will not drop down to 25 lbs to activate the switch to shut off the compressor. I even installed a new pressure cycle switch to no avail since the pressure will not drop enough to activate it anyway. So every half hour or so, I have to manually shut off the compressor at the control panel for about 5 minutes, and then start the process over again. The rear unit is controlled by the TXV and continues to function just fine (rear register temp 36-40 degrees). Any ideas on this? Thanks.
    Is it freezing up while driving or while idling at 1200 rpm during your test?

    Try revving the engine to 2000 rpm and watch the low side pressure.

    Usually, when the evaporator freezes up, it is low on charge.

    This happened on my 2001 last week during my 400 mile trip. It was low on charge. I found a small leak at the cycling switch. I just recharge the system with half a can of R134A and everything is fine after that.
    2011 Chevy Silverado LT 4WD 25k miles
    2001 Suburban 2WD, 5.3, V8 176k miles
    1993 964
    1996 318TI

Similar Threads

  1. 97 Suburban AC not cold
    By boycbronco in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last Post: 08-09-2011, 11:02 AM
  2. cold draft in 98 suburban
    By 98chevman in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 01-05-2011, 08:22 PM
  3. Replies: 7
    Last Post: 09-27-2010, 05:31 PM
  4. 94 Suburban wipers only work when it's cold outside
    By Gnant in forum Chevy SUV & Crossover Tech Forum
    Replies: 3
    Last Post: 09-06-2010, 04:24 PM
  5. 99 Suburban-Cold Start
    By 99fxst99 in forum GM Powertrain
    Replies: 3
    Last Post: 01-23-2009, 08:27 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •