GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9

Thread: namron67

  1. #1

    Default namron67

    1995 GMC Sierra 4X4 Carburated, Won't idle, have to pump accelerator to rev. engine. when holding throttle 1/2 open engine acts like it is starving for fuel, installed new fuel filter.

    This is my first post.

  2. #2
    Sr. Engineer
    Join Date
    Oct 2010
    Location
    Indianapolis, In
    Posts
    493

    Default

    Welcom to the forum. What carb do you have and can you verify fuel pressure at the carb. Tell us a little more about your set up as it doesn't sound like stock.
    2000 GMC YUKON SLT, 5.3L tow pkg, G80 rear/w 3.73 gear

  3. #3

    Default

    Quote Originally Posted by dpeter View Post
    Welcom to the forum. What carb do you have and can you verify fuel pressure at the carb. Tell us a little more about your set up as it doesn't sound like stock.
    I was completely wrong. It is not a carburetor, it is a 5.7L TBI (Throttle Body injector) I don't have the pressure testing gauge, but I will get one and let you know. Thank you

  4. #4

    Default

    Is the Check Engine Light on? Do you have any codes in the PCM?
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  5. #5
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,390

    Default

    Clean up your AIC, its a free fix and many times its the culpret
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  6. #6

    Default

    I was completely wrong. It is not a carburetor, it is a 5.7L TBI (Throttle Body injector)



  7. #7

    Default

    The fuel pressure barely registered. Tomorrow I will drop the fuel tank. I hope this message gets to you.
    Thank you for your help

  8. #8
    Master Mechanic Jimmeh's Avatar
    Join Date
    Apr 2009
    Location
    Columbia Falls, Montana, United States
    Posts
    806
    Blog Entries
    3

    Default

    Let us know if the new pump fixes the problem!
    2005 Chevy Silverado W/T
    4X4|4.8 with some mods (has only slightly more pull than a 5.3)|Auto|4 door ex cab|Cooper Discoverer AT/3's in 285-75/17's on Helo 842's|Cooper Discover M+S 265-75/17's on Devino DV349's|Flowmaster 40 Single in Dual out with custom bent pipe from the end of the cats back|2" Procomp leveling kit|Custom made center console|Custom dyno tunes|Air Raid CAI|Air Raid Throttle Body Spacer|Apex brand topper|Kenwood Head Unit with Kenwood speakers|Painted mirrors/grille|Debadged except front emblem|Bilsteins front and rear
    Planned mods not in order
    2 inch lift|Custom front/rear bumper|hitch tire carrier|roof basket on topper, bars on cab|finish center console build|install Midland CB|Power options|Tint|Custom made raised bed in the bed of the truck|Lund LunarVisor
    Also have a 1992 Ford Ranger with a lot of stuff done to it. Currently waiting for a bit of a rebuild.


    "The only woman I'm pimping from now on is Sweet Lady Propane. And I'm tricking her out all over this town."

  9. #9
    Sr. Engineer
    Join Date
    Oct 2010
    Location
    Indianapolis, In
    Posts
    493

    Default

    Sounds like you're on the right track. I also hope you have or had some help for that tank!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •