GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5

Thread: Strange Issue

  1. #1
    Jr. Apprentice
    Join Date
    Feb 2009
    Location
    Where Uncle Sam sends me (currently Jacksonville, NC)
    Posts
    26

    Default Strange Issue

    Hey guys, got a weird problem here. My wife was driving her '03 Trailblazer the other night, and when she switched on the brights, the engine died. She switched the brights of and cranked it again, and a few mintes later, when she hit the brights again, the engine once again died. Leading up to this issue, she's noticed the left turn signal blinks fast, as if one of the bulbs or the relay is bad, but it only happens intermittently. And when it is happening, the A/C isn't cooling properly. I've changed the bulbs for the signals and ensured that the A/C was charged properly, but this new brights/enine failure issue has me stumped. Anyone experienced anything similar, and if so, what advice can you give? Thanks.


    Chris
    Last edited by cmcoram; 07-21-2012 at 11:47 AM.
    Chris
    '03 Trailblazer
    '04 Colorado Z71
    Previous Chevys: '89 & '91 S-10 Pickups, '98 S-10 Blazer

  2. #2

    Default

    Hmm, I've never experienced this issue but may be able to lend a hand. Have you checked the battery, if not that may be it. Seems like the vehicle doesn't have enough juice to power everything. If your battery is good then I would check the alternator, it could be the vehicles power is not being distributed equally.. If you don't feel comfortable checking these things then you can always goto your local car/part store and I'm sure they would be more than happy to assist you. Best of luck!

    -Forum runner for iPhone


    2009 Chevy Silverado!

    Blacked out tail lights + 3rd brake light
    l Tint: 35% front windows and Limo on the rest l Hard wired Valentine One radar detector l Pirelli Scorpion Ice & Snow tires with GM CK375 wheels l Hand welded receiver hitch l HID lighting l SMD lighting l Blacked out front and rear emblems l Cherry Bomb Extreme exhaust dumped l 2 Kenwood 12's powered by a Kenwood amp w/ an Base control l

    2007 Chevy Tahoe LTZ---2012 Chevy Cruze
    ---

    "Let's just agree that a perfect truck is hard to find, and we'll drive the Silverado till we find it." - Car and Driver

  3. #3

    Default

    I agree, sounds like a alternator/battery issue to me.

    Alex


    2011 GMC Sierra SLE 5.3 Z71 4X4 Stealth Gray Metallic / 2004 Chevy Impala LS 3.8 Cappuccino

    Tow mirrors - Diablew Tuned - Flowmaster Regular 40 - Ready Lift 2.5' lift - BFG LT A/T K/Os - Carr Light Wing - TruckLite LED lights - Optima Red Top - 50% Front Window Tint - Line-X bedliner - Airaid MIT - Tekonsha P2 - ARS Billet Grill - Fia custom fit seat covers

  4. #4

    Default

    Ive seen a poor ground to chassis do similiar wierd things like this with headlights. Make sure your grounds are sound.




    2011 Silverado CrewCab 5.3L*Ram Air Look Cowl Induction Reflexxion Hood*6" Pro Comp Lift*Flowmaster Dual exhaust*Perfect Launch Rear Diff. Cover*Led Smoke Taillights*L.E.D.Smoke 3rd Brakelight*60" L.E.D. Tailgate Bar*Rearview Mirror Reverse Camera and Sensors*Smoke Headlight Covers*Front Bumper Grill Insert*Deezee Black Alum. Diamond Rail covers*20" Ultra Motorsports Rims wrapped with 35.5"B.F. Goodrich Tires*Inchannel Raingaurds*CAI*Bullydog GT Tuner*Alpine Amp*Boss 6x9's*Boston Acoustic Subs*Terrantula Tweeters*Custom Sub box*Red Led Interior Accents*5% Ultimacool duo tint rear window and doors, 20% front doors*Custom Vinyl Graphics*Demolded*Debadged*Painted drums and calipers*
    Future Mods Include: Custom Interior Hydrographics, Electronic Rollup Toneau Cover, 4.56 Gears, Painted rear bumper

  5. #5
    Jr. Apprentice
    Join Date
    Feb 2009
    Location
    Where Uncle Sam sends me (currently Jacksonville, NC)
    Posts
    26

    Default

    Thanks for the advice. I recently changed the battery, and the alternator checked out ok at that time. But that was a couple of months ago. I'll have it checked again. Thanks again for the replies and advice.

Similar Threads

  1. AC knob only works on full power/ strange fuel issue today-2004 Colorado
    By tom ruth in forum Chevy Truck Talk & GM News
    Replies: 1
    Last: 07-19-2012, 10:30 PM
  2. Strange starting/rough running issue - '96 5.7L
    By Soundside in forum GM Powertrain
    Replies: 9
    Last: 06-25-2012, 09:33 PM
  3. Strange Transmission Issue
    By Arkadios in forum Chevy C/K Truck Forum
    Replies: 6
    Last: 04-19-2012, 03:52 PM
  4. Replies: 8
    Last: 06-25-2011, 04:32 PM
  5. Strange radio issue
    By TELORVEHC in forum Audio, Video & Gadget Tech
    Replies: 1
    Last: 05-21-2011, 12:33 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •