GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3

Thread: Sarting trouble

  1. #1

    Default Sarting trouble

    First things first. It's an 2002 Suburban LS. 5.3 flex fuel. Daily driven and has never had any prior issues or warning signs of failure. This morning I went to turn it on amd to my surprise, it would not start. It has never done this and was driving fine two nights ago on my way home from work. Sat yesterday because I did not go anywhere. Went to start it this morning and got nothing. I could hear the fuel prump priming, so I kinda thought thay was eliminated. Could be wrong here, but I have always been told that if you could hear it, it's probally good. It was my first thought because I had a pump die on me when I owned a Blazer. I tried naturalky starting it a few times with no luck. One time it started, but died instantly. The battery, starter, etc are all fine. I don't think it's electrical as far as starting goes. I sprayed some starter fluid in the intake and had a bit more success. It came on, but idled very roughly and died. Did this a few times and got the same result. Would idel roughly for a minute, maybe two and die. If I hit the gas during this, all but once it dies instantly. I'm no mechanic other than normal stuff here and there. Brakes, oil, a radiator, etc. Things I have changed. Any and all help with this would be greatly appreciated. I had to run out for a bit, so I took the wifes Equinox, but hoping to take care of this when I get home. Thanks to all in advance.

  2. #2

    Default

    If spraying starting fluid into the intake makes it fire then its definately a fuel delivery issue.
    Kinda rule out the injectors because the odds of all of them going bad at once would be rare, not impossible, just rare.
    Next check would be the fuel filter, its cheap enough so if you take it out to check it just replace it anyways.
    Then a fuel pump pressure check, just because you hear it priming doesnt mean its sending anything up front.
    Also check all the fuses, under hood and under dash.

  3. #3

    Default

    Holy crap. Even with over a quarter tank full of gas it wouldn't start because I was parked on a ridiculously steep hill facing downward. It never crossed my mind that it would be the problem because it had a decent amount of gas. Oh well. Glad it wasn't anything serious. Thanks anyways. I had bought the filter previously because I had intended on changing it anyways. Might as well do it this week. Thank you.

Similar Threads

  1. 4WD trouble
    By mrdune in forum GM Powertrain
    Replies: 5
    Last: 10-09-2010, 03:07 PM
  2. Anyone have cat trouble?
    By clgoch187 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 11
    Last: 09-07-2010, 05:33 PM
  3. RIM - Trouble!!!!! PLEASE HELP
    By CanadianFrybag in forum Chevy Truck Accessories
    Replies: 3
    Last: 07-11-2010, 10:44 AM
  4. Trouble with a CAI
    By jjjg_02 in forum General Chevy & GM Tech Questions
    Replies: 7
    Last: 01-07-2010, 07:13 PM
  5. A/C trouble
    By BajaMark in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 07-06-2008, 09:42 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •