GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6

Thread: Odd issue

  1. #1

    Default Odd issue

    Ok i have a 98 k1500 5.7 vortec. Ok so here is what is going on. I put a new plentum and intake gasket on my truck and now it will not start. The only way i can get it to start is to advance the timing by 1 tooth and unplug the tps. If i advance or retard the timing at all it will not start. I have checked the tps and even replaced it, the old one and new one where both good. I do not know what to do. When the truck is running and you plug in the tps it dies immediately. Any ideas would be great. I need help bad!!!!!!!

  2. #2

    Default

    Toss us some more info.

    Why did you change the intake, was it damaged?

    Can you go back to the old intake and see if it runs normally?
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3

    Default

    I just replaced the upper and lower intake. I just got the truck recently and it has a lot of miles on it. I heard they were prone to failure so i decided to replace them. Right now the scan tool is showing that its running at 20 degrees out.

  4. #4
    Sr. Engineer
    Join Date
    Oct 2010
    Location
    Indianapolis, In
    Posts
    487

    Default

    Does this engine have a distributer and was it neccessary to remove it to replace the gaskets?
    2000 GMC YUKON SLT, 5.3L tow pkg, G80 rear/w 3.73 gear

  5. #5

    Default

    Yes it needed to be replaced. It has a distributor but its fuel injected. Any other thoughts or ideas would be great.

  6. #6

    Default

    I think where dpeter was going, it is very easy to replace the distributor incorrectly, resulting in the timing being off.

    You may have to re-time the engine.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

Similar Threads

  1. Help!!! AC Issue
    By davidyoung601 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 2
    Last Post: 06-08-2012, 11:27 AM
  2. Hello, possible TPS issue?
    By Sierra2500 in forum GM Powertrain
    Replies: 4
    Last Post: 02-09-2011, 07:48 PM
  3. ABS Issue
    By Lumpo in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 1
    Last Post: 09-03-2009, 03:25 PM
  4. Issue with 4WD
    By Kraziken in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last Post: 12-21-2008, 09:26 PM
  5. K&N issue ..??
    By TahoeFever in forum GM Powertrain
    Replies: 10
    Last Post: 11-17-2007, 06:59 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •