GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6

Thread: Vents dont work

  1. #1

    Default Vents dont work

    MYac blows onlt threw the defroster vents and when i switch the knob it doesnt do anything just wondering what could be wrong i have a 04 Silverado

  2. #2

    Default

    Welcome to the club!

    The problem likely that the valve is not moving properly. My question is when u put it on feet does it blow at the feet?

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  3. #3

    Default

    Could also be the mode door actuator...

  4. #4

    Default

    no it doesent blow on the feet either just the defroster vents

  5. #5

    Default

    Well I'd look and see if the blower control motor is actually moving the linkage. do that by having truck on/in accessory position so air blows and play with the directional control and watch if the motor moves the linkage and such.

  6. #6

    Default

    There was a non-recall issue that GM would fix for free even on out-of-warranty cars, where moisture could get in and damage some of the blower control circuitry. Some of the symptoms are similar, so you might want to get it checked out at a dealer. The 04 Silverado I used to have had the issue, and they did the repair for no charge. I don't recall the TSB number though.

Similar Threads

  1. wipers dont work.
    By seffieldvillage@aol.com in forum Chevy Colorado Forum (GMC Canyon)
    Replies: 5
    Last: 11-02-2009, 09:31 AM
  2. it dont work
    By 5speedsilverado in forum Photo & Video Gallery
    Replies: 7
    Last: 07-16-2009, 08:56 AM
  3. gauges dont work
    By gmmax in forum Audio, Video & Gadget Tech
    Replies: 5
    Last: 05-12-2009, 01:05 AM
  4. Tail lights dont work
    By Dr_Zero in forum How-to Guides
    Replies: 5
    Last: 04-20-2009, 11:05 AM
  5. hi from ct 91 chevy 4x4 dont work
    By elkybeepa185 in forum GM Powertrain
    Replies: 7
    Last: 02-26-2009, 10:31 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •