GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 10 of 10
  1. #1
    Newbie
    Join Date
    Sep 2012
    Location
    Los Angeles Ca. U.S.A
    Posts
    5

    Default Engine Lubrication

    Hello I'm new at this site and I need some clarification for problem that I came across and I think I got it right.
    This is for a

    2002 GMC Truck 1500 2WD V8-5.3L VIN T

    The truck was driven with the flashing engine oil level light, the gauge maintained an over 40psi pressure reading, the engine ran out of gas.

    We added oil and gas but the engine kept starting and shutting off - We installed a new fuel filter and then it ran for about a minute until a knocking sound came out of the engine and it completely shut down and now the starter doesn't even make an effort to start the engine.

    My best guess is that the oil pump give up, even though it was reading over 40psi.

    My question is:
    Is it fair to say that the knock sensor with the help of the low oil pressure sensors and possibly other sensors, took notice of this conditions and the PCM went in to a no start safe mode in order to prevent further engine damage?

    Thank you for reading.
    GMO
    :glasses:

  2. #2

    Default

    My guess is, you ran the engine without oil and the engine seized.

    That is the worst case scenario, the PCM should shut down the engine if there is no oil pressure.

    It (the PCM) will not stop you from trying to start the engine, the engine should spin.

    You may have a bad starter in the middle of all of this and the starter is the reason you can't start.

    You may have a dead battery and the battery is the reason the starter can't spin the engine.

    You may have left the transmission shifter in gear and that is the reason the starter is unable to start the engine.

    You might have a defective starter relay in the fuse box,

    You might have a defective starter solenoid (but, a lot of people consider this to be part of the starter),

    You might have a defective ignition switch.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  3. #3
    Legend

    Join Date
    Jun 2006
    Location
    River Ridge Louisiana-4 miles W of New Orleans-didn't flood-water stopped 800 yards away.
    Posts
    1,613

    Default

    How much oil did you have to add to get the dipstick to FULL?
    How long did you run it with the engine oil light on?
    How far-at what speed?
    If you had to add 3.5-4 qts- it was nearly empty
    2 qts- not great but not horrible either
    1qt-who cares-no problem.
    Did it make a metallic squealing sort of noise before it shut down.
    Don't ask me how I know what sort of noise an engine might make when you run it as all the oil is draining out a double o-ring unseated oil filter.
    Oh that truck-a little 4 cyl Toyota-ran for 100,000 more miles-then sold it-but it started right up-and it wasn't run for long distances on low then lower then extremely low worn out oil-like yours might have been.
    Why was it low on oil-a leak-or just using oil?
    Luck
    Charlie
    1998 suburban-
    1/2 ton

    199500 miles
    River
    Ridge,LA

  4. #4
    Newbie
    Join Date
    Sep 2012
    Location
    Los Angeles Ca. U.S.A
    Posts
    5

    Default

    Hello RayVoy Thanks for the input.

    Well, after the engine started for about a minute, it made the knocking noise and it shutdown by it self, I did try to start it again but there was no response by the starter but I was able to turn the engine's crankshaft by hand.

    Thanks again.

  5. #5
    Newbie
    Join Date
    Sep 2012
    Location
    Los Angeles Ca. U.S.A
    Posts
    5

    Default

    Hello phoebeisis Thanks for the input.

    Yeah! It was nearly empty and it ran for a few days with the low level light on at fair street speeds ( but the gauge indicated over 40psi! )

    No Metallic Squealing Noise Ever..

    No leaks anywhere so my best guess is that the truck used up the oil..

    Thanks

    GMO LA Cali.

  6. #6

    Default

    Ok GMO, I was going to suggest you try to turn the crank by hand. SOOOOOOOOOO, good news, the engine is not seized.

    Can you hear/feel the starter relay operate in the front fuse panel?

    Ya know, if indeed, the PCM is causing the problem maybe just a reset is all that is needed. Try disconnecting the battery for 10 mins.

  7. #7
    Newbie
    Join Date
    Sep 2012
    Location
    Los Angeles Ca. U.S.A
    Posts
    5

    Default

    Yes yes, disconnecting the battery works and the relay is okay but I do not want to start up the engine anymore since I heard the first sounds of a bad oil pump which the knocking only..

    Tell me, is it a good idea to replace the oil pump with out lifting the truck- on the floor?
    Do i need the oil pan gasket, the timing cover gasket, any special tools other then the harmonic balancer puller?

    Thanks again.

    GMO

  8. #8

    Default

    A 2wd truck should provide enough room to get the pan off, and out from under, the engine.

    If I was going to tackle this job, I'd pick up a Hayes manual ($15.00) on the truck, or on GM engine repair. Then you've got the step by step in front of you.

  9. #9
    Sr. Engineer
    Join Date
    Oct 2010
    Location
    Indianapolis, In
    Posts
    493

    Default

    Consider this, if it was knocking then an oil pump will not be the only repair you should or will be making. Why do you think the pump needs changed? From your first post you stated it had pressure but only low oil level... what changed?
    2000 GMC YUKON SLT, 5.3L tow pkg, G80 rear/w 3.73 gear

  10. #10
    Newbie
    Join Date
    Sep 2012
    Location
    Los Angeles Ca. U.S.A
    Posts
    5

    Default

    Hey guys, thanks for all the info, here is an update and wind to top it off..

    Yeah! I have ALLDATA to aid me plus over 20 years experience in the automotive repair industry, I was just in denial about this whole thing, I wanted to hear good news but the fact is that I screwed up..

    Anywho.. I hand turned the crankshaft and heard some metallic screeching sound coming from the crank case- well you know what that means..
    Oh! But still the starter wouldn't even make a click, the relay does but nothing else..

    Where does the oil go?
    I will do an oil change and by next month the engine will ask for more!

    I used to have a 1977 Chrysler Cordoba and the engine oil level would stay the same for a very long time, yes it would be black and thick but it would still be in there- This stupid GMC Sierra consumes the oil- it makes it disappear and were does it go?
    I bet is all carbonized in the engine- What the hell man! I bought this truck new in 2002 thinking that I'll be helping the U.S. Economy and look at the piece of crab I ended up with! Even a Toyota last longer than this crab!

    So My FN Truck don't only consumes gas but oil as well, Umm! Makes perfect sense, No FN Wonder I been hearing all along that American Cars now days SUCK..

    HAHA!

Similar Threads

  1. Diesel engine weight-v-Gas engine weight ?
    By kingriver in forum The Coffee Shop ~ Chit Chat
    Replies: 4
    Last: 09-19-2011, 05:28 AM
  2. New Engine, Old Engine Question
    By Goldie in forum GM Powertrain
    Replies: 4
    Last: 08-25-2011, 04:45 PM
  3. remove engine mounts/ raising engine help
    By Lifted_Bowtie in forum GM Powertrain
    Replies: 1
    Last: 02-05-2011, 07:43 PM
  4. Replies: 0
    Last: 09-29-2009, 02:46 PM
  5. Ward's AutoWorld honors Flint Engine South 3.6-liter V-6 engine - MLive.com
    By ChevyFan in forum Chevy Traverse Forum (GMC Acadia, Buick Enclave)
    Replies: 0
    Last: 01-16-2008, 12:40 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •