GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4

Hybrid View

  1. #1

    Default 91 k2500 5.7 5spd manual electrical issues?

    Ok so I bought a 91 k2500 5.7 manual tranny. Ran good for the first five days then died. I replaced the fuel pump relay and fuse, fuel pump and module, ecm and distributor which includes a new ignition coil. The problem I'm having is that 1. The fuel pump doesn't prime and 2. The injectors will not pulse. I've tested the injectors with a couple jumper wires they open. I could use some ideas. I should add that the injectors aren't receiving the pulsing ground, and that I tested those wires for continuity from plug to plug between the injectors and ecm and ecm to distributor and they are fine.

  2. #2

    Default

    It sounds like you have no juice at the pump. Check the wires at the pump for voltage and chassis ground. If you have power and ground at the tank then you have a broken wire inside the tank.
    "It went together didn't it? Well then there has to be a way to take it apart!" - Me.

    Check out my image gallery HERE.



    "The true measure of a man is how he treats someone who can do him absolutely no good." ~Samuel Johnson (1709-1784)

  3. #3

    Default

    I just replaced the pump module 3 days ago. Nothing wrong with the wires inside the tank.

  4. #4

    Default

    Ever get this fixed? Does it have spark?
    Spark may seem unrelated but I'm curious if the engine is A: actually powering up when you turn the key to on and B:aware that it is cranking over when you turn the key to start. Were it not for the fuel pump not priming I would have only wondered about the second, but with no injector pulse OR fuel pump relay switching on when you turn the key to on I would almost suspect something in the ignition switch.
    One of the funniest (in a piss you off way) glitches I ever saw was a truck that would lose key on power in the cranking position due to a problem with the electrical part of the ignition switch, so it would actually power on fine and then do nothing but crank in the start position, it would actually fire as you were letting off the key because the engine was still spinning and it would get power when the key returned to the on position. That was entertaining to find to say the least.

Similar Threads

  1. 2000 gmc sonoma 5spd shift issues?
    By sk33mcg33 in forum Chevy S10 Forum (GMC Sonoma)
    Replies: 1
    Last Post: 06-15-2012, 04:27 PM
  2. 1991 Chevy/GMC C/K electrical service manual
    By Revredneck in forum General Classifieds
    Replies: 0
    Last Post: 07-15-2011, 04:12 PM
  3. Hard shifting/ squeeking on 5spd. manual
    By Crispyt in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 04-15-2011, 01:37 PM
  4. k2500 not shifting - electrical issues?
    By carl s. in forum Chevy C/K Truck Forum
    Replies: 1
    Last Post: 05-24-2009, 09:53 PM
  5. 96 k2500 electrical schematic
    By krashomatic in forum Chevy C/K Truck Forum
    Replies: 2
    Last Post: 05-12-2008, 07:16 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •