GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13
  1. #11

    Default

    I had a similar issue driving on highway in cruise. Took it off cruise and turned off air, pulled off road and shut off. All looked good under hood. Stopped by autozone, got codes checked, all good. Put Seafoam in fuel. Figured wwater in fuel. Have not had problem since. We'll see how long it lasts
    2003 Suburban 2500 LT, 6.0l Volant cai. 3.73 gear. Mobil 1 syn oil

  2. #12

    Default

    Last month, I did a fuel pressure test and only got like 40-45 psi. Fuel pressure was also dropping to zero psi in about 2-3 minutes.

    When I checked my 2011 5.3L silverado, fuel pressure registered at 55 psi and held for a long time. So I knew then that something is wrong with the fuel delivery system. I went ahead and bought a new fuel pump module and fuel pressure regulator. I dropped the tank, pulled the old fuel pump and put the new one in half a day. Also replaced the FPR.

    It has been running really running good after the parts replacements. It already has about 165k miles.
    2011 Chevy Silverado LT 4WD 25k miles
    2001 Suburban 2WD, 5.3, V8 176k miles
    1993 964
    1996 318TI

  3. #13

    Default

    I did not read all the replies on here but had something similar on a 98 not too long ago. When you say bucking, does it feel like it is cutting on and off, almost like a fuel problem? I thought the same thing for months and it would not happen all the time. I changed filter, ran seafoam and other injector cleaners through it, etc. It turned out to be he coil of all things on the way out. I changed the coil and not a problem since.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Vortec 6.0 Ideal Highway(60MPH) RPM
    By graknil in forum Performance & Fuel
    Replies: 1
    Last Post: 12-05-2010, 12:42 PM
  2. 1994 Suburban Engine missing
    By mcgee1756@hotmail.com in forum GM Powertrain
    Replies: 2
    Last Post: 08-03-2010, 10:40 AM
  3. bucking between 55-70 mph
    By dsquared in forum GM Powertrain
    Replies: 17
    Last Post: 06-01-2010, 02:55 PM
  4. 99 c1500 5.7 suburban missing at idle when hot
    By i_build in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last Post: 10-22-2009, 06:08 PM
  5. 95 Suburban either missing, or fuel cuts out.
    By pook7one in forum GM Powertrain
    Replies: 4
    Last Post: 01-23-2008, 03:10 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •