GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1
    Master Mechanic Jimmeh's Avatar
    Join Date
    Apr 2009
    Location
    Columbia Falls, Montana, United States
    Posts
    806
    Blog Entries
    3

    Default HEEEEELP! 2000 Silverado has a major electrical issue!

    THIS IS MY DADS TRUCK!

    A few months ago, the fuel pump went out in my dads truck, and he finally replaced it today. He had to jump start the truck for it to go, and he said he ran it for a long time with no issues. When he got home, he plugged it into his battery charger to try to get the volts back up. The charger said the battery was about 85%, so we figured it was high enough to start. When he turned the key to "on", we noticed the lights were very dim on the inside, and when he tried to start it, the starter made a hellacious noise (just clicks), the headlamp relay buzzed like a bug zapper and all the lights on the dash were flashing and flickering like crazy!

    To back up just a little bit, last week or the week before, I got into his truck to grab something, and triggered the alarm. Apparently, he accidentally hit the lock button, but his passenger side door did not lock fully. Since he wasn't home, we couldn't stop the alarm from his key fob, but it eventually stopped on it's own (no horn, the lights were flashing and the relay was clicking). I am wondering if there is some correlation between the two things. If you guys can help me out, that would be awesome! I was trying to tell him how to reset the passlock on the truck, but he's stubborn as hell and can't wait for 10 minutes. Either way, the security light only flashes with the key turned one click or the door open, like normal.
    2005 Chevy Silverado W/T
    4X4|4.8 with some mods (has only slightly more pull than a 5.3)|Auto|4 door ex cab|Cooper Discoverer AT/3's in 285-75/17's on Helo 842's|Cooper Discover M+S 265-75/17's on Devino DV349's|Flowmaster 40 Single in Dual out with custom bent pipe from the end of the cats back|2" Procomp leveling kit|Custom made center console|Custom dyno tunes|Air Raid CAI|Air Raid Throttle Body Spacer|Apex brand topper|Kenwood Head Unit with Kenwood speakers|Painted mirrors/grille|Debadged except front emblem|Bilsteins front and rear
    Planned mods not in order
    2 inch lift|Custom front/rear bumper|hitch tire carrier|roof basket on topper, bars on cab|finish center console build|install Midland CB|Power options|Tint|Custom made raised bed in the bed of the truck|Lund LunarVisor
    Also have a 1992 Ford Ranger with a lot of stuff done to it. Currently waiting for a bit of a rebuild.


    "The only woman I'm pimping from now on is Sweet Lady Propane. And I'm tricking her out all over this town."

  2. #2
    Sr. Engineer
    Join Date
    Oct 2010
    Location
    Indianapolis, In
    Posts
    487

    Default

    Check the battery connections first then if that does not improve things then have the battery checked at your local parts store.
    2000 GMC YUKON SLT, 5.3L tow pkg, G80 rear/w 3.73 gear

  3. #3

    Default

    Quote Originally Posted by Jimmeh View Post
    I am wondering if there is some correlation between the two things.
    Nope, doesn't sound likely. The car alarms will always turn off after 10 minutes or so (give or take, depending on the brand/model).

    Sounds like you have a bad battery. The drain on the battery is tremendous during cranking, and it just couldn't output the raw amperage. Either charge it 100% and try again, or take it in and have it tested. I strongly suspect a new battery will fix the issue, as dpeter notes.

    -Skippy
    2006 Vortec Max 1500
    Performance:
    -Custom Tune (389HP 440 Ft/lbs Trq - Dyno'd) | Volant CAI | Magnaflow Dual-in/out Exhaust w/3" stainless pipe tips | Fully Built Transmission w/ Red Eagle Clutches & Kolene Steels w/ Corvette Servos and Stage2 Shift Kit | 35K Tranny Cooler | Mobil 1 | Royal Purple Rear Diff
    Other:
    -Spray-in Bed Liner
    -Premium Sound w/lifetime Satellite Radio | Leather | Sunroof | Heated Seats
    -Limbstriping from USING the truck (those are badges of honor)

  4. #4

    Default

    Have a local shop check the battery for any dead cells.

  5. #5

    Default

    I would say the battery and maybe have the alternator checked also, but the alternator does not sound like it is the problem.

  6. #6
    Master Mechanic Jimmeh's Avatar
    Join Date
    Apr 2009
    Location
    Columbia Falls, Montana, United States
    Posts
    806
    Blog Entries
    3

    Default

    You guys rock! It was indeed a dead battery cell.
    2005 Chevy Silverado W/T
    4X4|4.8 with some mods (has only slightly more pull than a 5.3)|Auto|4 door ex cab|Cooper Discoverer AT/3's in 285-75/17's on Helo 842's|Cooper Discover M+S 265-75/17's on Devino DV349's|Flowmaster 40 Single in Dual out with custom bent pipe from the end of the cats back|2" Procomp leveling kit|Custom made center console|Custom dyno tunes|Air Raid CAI|Air Raid Throttle Body Spacer|Apex brand topper|Kenwood Head Unit with Kenwood speakers|Painted mirrors/grille|Debadged except front emblem|Bilsteins front and rear
    Planned mods not in order
    2 inch lift|Custom front/rear bumper|hitch tire carrier|roof basket on topper, bars on cab|finish center console build|install Midland CB|Power options|Tint|Custom made raised bed in the bed of the truck|Lund LunarVisor
    Also have a 1992 Ford Ranger with a lot of stuff done to it. Currently waiting for a bit of a rebuild.


    "The only woman I'm pimping from now on is Sweet Lady Propane. And I'm tricking her out all over this town."

Similar Threads

  1. Help! electrical issue...I think?
    By chopper1 in forum General Chevy & GM Tech Questions
    Replies: 6
    Last Post: 12-17-2011, 08:29 PM
  2. 2000 Silverado Electrical Power Outtage
    By Velocity1 in forum Chevy Truck Tech Forum
    Replies: 1
    Last Post: 05-07-2010, 02:36 PM
  3. 2000 Silverado C1500 Electrical issues
    By 99vortec in forum General Chevy & GM Tech Questions
    Replies: 10
    Last Post: 01-03-2010, 08:50 PM
  4. Major Electrical Outage in 04 Tahoe
    By Craig789 in forum Audio, Video & Gadget Tech
    Replies: 3
    Last Post: 07-16-2009, 03:41 PM
  5. major electrical issues, stalling, flashing lights, cruise malfunctions.... help?
    By kawasaki_kid in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 05-20-2009, 07:10 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •