GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: New Problems

  1. #1

    Angry New Problems

    So recently after doing some repairs on my truck (replacing belt tensioner pulley) the squeaking and screeching from under the hood pretty much stopped. It happened on and of for very short time last week after it was fixed, but then this week its back full force but still only randomly.

    The new issue is that when ever it squeaks the volt gauge goes from the normal 14 down to less than 13. It rarely squeaks but its a pain in the butt and as loud as it was before the fix if I steer at low speed during. It seems the new pulley is hurting more than the old and now my alternator is facing the consequences. I was going to replace the idler, but now I wont until I get in the AC Delco part because I don't trust another one of Autozone's rebadged Dayco pulleys. This is the first time I've had a problem with Autozone's house brand every other one of their products I have bought have worked very well.

    I'm not sure what to do right now. Currently I'm working on ordering a new AC Delco full tensioner unit and idler as well as a Goodyear Gatorback belt and new 140 amp AC Delco external fan alternator. (the one under the hood was a temp anyway only has a 1yr warranty)

    Link to what I did and pics: http://www.gmtruckclub.com/forum/sho...#axzz26U420CXc
    Last edited by Conlan Rose; 09-14-2012 at 05:00 PM. Reason: add link

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  2. #2

    Default

    So I tried to take a video to show what I mean its really blurry at parts but you can clearly hear the squeaking and squealing and see the voltmeter. Sorry for so much background noise and shakiness its hard to hold your phone still and steer with one hand.



    See when it squeaks the alternator doesn't run as good but the second the alternator goes to norm it stops.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  3. #3

    Default

    Well replaced the idler helped a little bit but still squeaks occasionally. Usually on turns mainly left ones as my dad noted after I gave him a ride today. but some times when going straight. So might mean the powersteering is going.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  4. #4

    Default

    If your power steering pump bearings are worn out and it is binding up, it will cause the belt to slip and raise hell. Can you feel it in the steering when it happens?
    "It went together didn't it? Well then there has to be a way to take it apart!" - Me.

    Check out my image gallery HERE.



    "The true measure of a man is how he treats someone who can do him absolutely no good." ~Samuel Johnson (1709-1784)

  5. #5

    Default

    No the steering feels just like it did when I bought the can and like any car with power steering nice and smooth. Not having any problems other than something is raising hell under the hood.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  6. #6

    Default

    This is really irritating and frustrating. Its it possible the tensioner isn't working right and causing slipping. Btw the current belt under the hood is a Goodyear gator back belt. Every other accessory except for the alternator is factory. But the tensioner unit is dayco/duralast now with a new pulley. The compressor is new but was done by GM before I bought the truck. Old idler looks a lot beefier then the dayco/duralast one. The steering is working great and I have vacuum brakes not the ones the work with the power steering so no problems with brakes like @Kady said she had with her old burb. Luckily the pump isn't to much but I don't wanna replace it if I don't have to.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  7. #7

    Default

    Ok so after driving all over today I figured out that it only begins to squeak when the truck is idling but as soon at the truck is at speed it usually goes away, but goes away the second it hits 2000 rpm no matter what. I have no clue what to do. Everything on the truck is acting normal and no trouble lights are coming on accept for the ABS but that was on before the problem started. Please I need to fix this before the winter and before I no longer have any free time because of school, scouts and sports.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  8. #8

    Default

    Sounds like belt slippage. I would try a new belt.
    Ray

    '09 Avalanche LTZ - Black
    '05 Envoy XL (sold)

  9. #9

    Default

    Wah I thought that was an option but I kinda don't wanna spend the money on a new belt if I'm replacing the current alternator with a 140 amp one. Guess that mod is coming sooner then later. I will be ordering that this weekend then with the gator back 140 amp belt.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

  10. #10

    Default

    Change in plans will be saving up for alternator and buying cheapo valuecraft belt for temp.

    1996 Chevy Tahoe LT 5.7L V8 4X4 205,000+ miles. Built proudly at Janesville Assembly in Janesville, Wisconsin
    Basic mods: Lights all over, bunch of electrical work, and a couple cooling mods.

    Check out my other mods in My Garage: http://www.gmtruckclub.com/forum/sho...t-Tahoe-4-Door

Page 1 of 2 12 LastLast

Similar Threads

  1. 96 Suburban Turn Signal Inop, ABS Problems & Convertor Problems
    By rowekmr in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 05-14-2012, 04:43 PM
  2. EGR Problems
    By revscott in forum Chevy C/K Truck Forum
    Replies: 13
    Last Post: 04-05-2012, 12:38 AM
  3. Problems
    By Kdogg05 in forum Announcements & Feedback
    Replies: 2
    Last Post: 06-10-2008, 02:37 PM
  4. ac problems
    By terry16120 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 06-09-2008, 02:43 PM
  5. Chevy Silverado Heater problems blower problems
    By bidutch in forum GM Powertrain
    Replies: 3
    Last Post: 12-13-2007, 05:59 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •