GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Default P0442 Evaporative Emission Control System Leak Detected (small leak)

    I have a 1998 Chevy K1500 with the 305. I got this code the other morning. I had someone check it with scanner, and this is the code I got. I was not adding any gas at the time, so the cap was not off. The truck was running at a gas station, I was in getting my morning newspaper.

    Went to leave and the "service engine soon" light came on.

    This is what google say it is:

    This indicates a fuel vapor leak in the EVAP control system. It means a very small leak has been detected. In fact, the leak can be from a hole as small as 0.04" in diameter. The (EVAP) emission control system prevents the escape of fuel vapors from a vehicle's fuel system.
    Fuel vapors are routed by hoses to a charcoal canister for storage. Later, when the engine is running a purge control valve opens allowing intake vacuum to siphon the fuel vapors into the engine.


    I got the light cleared, check the cap, make sure it was on tight. Drove for about 150 miles and the light came back on. Pretty sure it is the same problem.

    Has anyone had a problem like this? and is there anything else I should look for??

    Thanks

    Dan

    My plan is to replace the cap, remove some rust that is on the filler neck and reset the computer again.
    Dan Malone
    Berlin, New Hampshire

  2. #2
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,321

    Default

    It's been a problem in a few trucks on here.. Just look around A few members have fixed them.. I gotta do mine before winter Cause my remote start will not work with that light on...
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  3. #3

    Default

    So an update, over the weekend, I cleaned some rust off the filler neck, replace the old gas cap with a new one. Today, when I filled up with some gas, I had the same "service engine soon" light on, I noticed some back pressure when I took off the gas cap. I put the gas cap on tight, when I started the engine, the light came on with all the other lights and "service engine soon" light went off.

    My question is, will the lights clear once the problem is fixed?

    Thanks
    Dan Malone
    Berlin, New Hampshire

  4. #4
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,321

    Default

    You can try reseting it. or dissconnect the Battery for 20 mins. Al just fixed his and we will do mine soon I used my scanner many times to reset but it comes back and My remote start will not work with the light on..
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  5. #5

    Default

    Thanks for the reply, my light cleared on it's own, just wondering if they reset once the problem has been fixed???
    Dan Malone
    Berlin, New Hampshire

  6. #6
    Legend


    Enkeiavalanche's Avatar
    Join Date
    Apr 2010
    Location
    Piermont,NY, back in Northern NJ now, But may be in IL soon....
    Posts
    5,321

    Default

    mine went off for about 2 days and came back on...
    08 Z71 Avalanche Mods to date: K&N CAI,Hellwig Swaybars and End Links, Corsa Sport Exhaust, Superchips Programer,IPCW LOF & 3rd brake light and tails, AMI Gas door,Show Hooks and Door locks, Enkei Wheels, with Pirelli tires, StreetScene Bowties, Grant Steering wheel,Muth signal mirrors,SSBC Big Brake kit,Huskyliner Mug gards,Floor mats and Hood shield, McGard Lug nuts and locks, Bedrug, Cervini's Ram Air hood,35watt HID Fog lights, Sylvania bulbs all around ZXE's Highs and Lows, WhiteNight Back up lights,Sirius and HD Radio, SnugTop sitting on deck now Got a Softopper on now,Tempress Boat Hatches.... New Bilstein shocks are on... New Mods coming soon..... X

  7. #7
    Jr. Engineer 4x4squared's Avatar
    Join Date
    Dec 2011
    Location
    Fort St. John, BC
    Posts
    224

    Default

    if the problem is fixed, the code will clear itself automatically....usually. try some vaseline around the rim of the filler neck if the code comes back on and itll help seal it up when the fuel cap is put back on. the fuel cap may also have a small crack or just be worn out to the point where it wont "click down" hard enough to get a good seal. if the vaseline doesnt work, just grab yourself a new fuel cap, theyre usually only like 5-15 dollars for a non-locker.



    5.7L 350| .420 Cam | Bored 0.030 | Edelbrock intake manifold | 600 Cfm Edelbrock Carburetor | Long tube headers | Shift kit | Chrome dress up kit | Flowmaster 40's exhaust | Edelbrock heads | Custom paint
    SOLD

    "Don't judge a book by its cover."

    HONORARY CANUCK

Similar Threads

  1. OBD Codes - cylinder 1 misfiring and Evaporative Emission Control - high input
    By coryanderson in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 01-10-2012, 07:41 PM
  2. noticed a small small coolant leak
    By 95WT in forum Chevy C/K Truck Forum
    Replies: 4
    Last Post: 10-24-2011, 03:53 PM
  3. A/C leak detection on empy system - 96 sub k1500 5.7
    By Rich50 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 04-20-2011, 11:30 AM
  4. gm leak tabs on 5.7 intake manifold leak
    By raceville in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 01-13-2011, 02:06 PM
  5. P0442 Evaporative Emission Leak Detected
    By Big_Ben in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 10-07-2010, 07:26 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •