GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default 1992 GMC S15 4WD 4.3 TBI running ruff and very rich need help

    I rebuilt my 4.3 TBI GMC S15 Blazer engine 18k miles ago. It has been running great until two weeks ago. The CAT melted down and I had 30 psi of back pressure. The engine ran very ruff. I had the cat and muffler replaced with new. The engine still is running very ruff and rich. The distributor is a MSD with new cap and rotor. The spark plugs were just replaced. The ignition leads are Magnecor and are new. I replaced the fuel filter and measure 12 psi fuel pressure steady at the filter. I tried a different MAP sensor, Ignition control module, a different TBI and the engine still is running very ruff and rich. I have checked the temp sensor with a scanner and the ambient temp is correct and the sensor is responding normal. The MAP sensor voltage is correct. The throttle position voltage is correct. The timing is bang on at 0 degrees with the base timing (wire under the dash disconnected). The O2 sensor measures correct as well. The EGR valve was just replaced also. I believe I am down to a bad ECM.

    Any thoughts or ideas or would be appreciated.

    Thanks in advance,
    Glenn

  2. #2

    Default

    Ok I was able to try my ECM and prom in another 1992 Jimmy S15. The other Jimmy ran great with my ECM and prom. Out of pure frustration I removed the MSD distributor and installed the factory stock distributor from the other Jimmy S15 into my Jimmy. My Jimmy S15 ran very smooth and had tons of power and was no longer running rich with the factory stock distributor. Problem solved. I will be contacting MSD about the distributor. The MSD distributor model is a 8367 and the one I purchased has major issues!!!!! Go figure.

Similar Threads

  1. Running very rich
    By ShadowRejects in forum Chevy C/K Truck Forum
    Replies: 4
    Last: 12-12-2011, 09:59 PM
  2. running rich
    By alw in forum Performance & Fuel
    Replies: 4
    Last: 03-21-2011, 05:22 PM
  3. Running rich problem
    By ftms in forum Performance & Fuel
    Replies: 18
    Last: 06-07-2010, 02:38 PM
  4. 93' GMC Sierra 350 running really rich... HELP!!!
    By GearHead899 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last: 05-15-2010, 11:18 PM
  5. Running rich
    By trivers in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 7
    Last: 11-18-2007, 02:12 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •