1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

03 silverado 1500 4.8L just died while driving

Discussion in 'General Chevy & GM Tech Questions' started by lqvision, Oct 15, 2009.

  1. lqvision

    lqvision New Member

    there was a whining coming from behind the cab. then it was sputtering and just died and now i cant start it. it wont even turn over. does anyone have any ideas? if its the fuel pump, and i replace it will the truck start again or is there something else that needs to be done first like restart the computer. please help me out asap. thank you
  2. Loggerhead Mike

    Loggerhead Mike Rockstar 100 Posts

    i was just fixin to reply to your other thread

    when you say turn over do you mean the engine will turn over but not crank or it wont turn over at all?

    do you have any power like lights ect ect? did you crawl under it and make sure no wires have been torn ?

    i would not guess and start throwing parts at it. if it comes to that take it to a dealer. get back to me with what you find and we'll get pointed in the right direction
  3. hook

    hook New Member

    I have the same truck and engine. When my fuel pump went it was like the ignition was turned off - no noise just dead. However, my engine would turn over - just wouldn't fire.
  4. lqvision

    lqvision New Member

    i found out that the PCM-B fuse under the hood was blown. put a new one in and now it works
    do you know what that fuse is? i think its the powertrain control module. more specifically what would cause that fuse to blow. im planning driving 3 hours out of town and dont know if i should.
  5. Tdaz250

    Tdaz250 Rockstar 100 Posts

    Sounds like your fuel pump went out. Or something with the fuel pump.

Share This Page