1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

03 Yukon XL instrument cluster hiccup

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by rbyrne, Jan 5, 2014.

  1. rbyrne

    rbyrne New Member

    Just purchased this Yukon XL a few days ago. Noticed that the airbag light, ABS, battery light all went on. The message board read check 4wheel drive and all the instrument panels went dead. The odometer and tach still worked. After a few minutes, I heard a ding and everything started working again. Then happened again later in the day, this time as I was parking at a store. When I came back out 15 minutes later, everything worked fine.

    Any ideas what to check?
  2. Pikey

    Pikey Moderator Staff Member 2 Years ROTM Winner 1000 Posts

    I would pull the cluster out and check the connections at the back. I have had to use a pick and bend the prongs out to make better contact.
  3. rbyrne

    rbyrne New Member

    It happened again, this time I was close enough to a computer hook up to see if any error codes registered. It came up as U1096 - Lost communication with driver information and displays (IPC) system. I have not checked behind the dash yet as it just got above 0 degrees again and I like the use of my fingers!

Share This Page