1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

04 2500HD 6.0L Tranny 4L80E Help, Think i have a big problem Please help!

Discussion in 'General Chevy & GM Tech Questions' started by stang233, Feb 10, 2011.

  1. stang233

    stang233 New Member

    Okay I have a 04 Chevy 2500hd 6.0l gas motor. It has 70k miles on it but not really any of them are towning miles. But i think there is a problem with my TRANSMISSION.

    PROBLEM: When i am driving on the freeway at cruising speed, so anything over 55 the tranny goes into overdrive as normal. BUT if i let off the gas at all, i mean just a hair the truck will come out of lockup, (not down shift just come out of lock up) and then when i reapply the gas it will go back into to lockup. Can you guys see if yours does this or is this normal for this truck. Shoud I pay the $100 to have the dealer look at it??????

    It has always done this since I have had it at 60k miles and I always am worried about it.

    I have a Hypertech but it does it if it is programmed or not. I have stock tire size and have not adjusted anything other than the 87 octane fuel in the controller. But i have tried it programmed and not and it still does it.
  2. 1991 Suburban

    1991 Suburban New Member

    I have a '91 Sub that does the same thing. Hasn't caused me any issues, though it can be slightly irritating. Even if this progresses into a real problem, it's not a transmission issue, just the torque converter. The torque converter is what locks up, giving you a better highway economy, and unlocks when you need more power.
  3. stang233

    stang233 New Member

    Update: the down upon acceleration is working right along with the lockup and unlock. I an able to accelerate a fair amount before it will unlock or downshift. It is only when I take my foot off the.gas a little or all the way it unlock then locks backup. Any advice guys
  4. knobber

    knobber New Member

    I have an 06 that did the smar thing. At about 100,000 the trany went out. I had it rebuilt with a new torque converter. It still did the same thing. I took it to the dealer and they programmed the computer and said it was good to go. I now have 122,000 on it and it is starting to do it again. I have to think it is something in the computer. I may get a new computer put in to see if that fixes it.

Share This Page