1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

'04 Avalanche Heater problems

Discussion in 'Chevy Avalanche Forum (Escalade EXT)' started by cleophus, Dec 19, 2011.

Random Gallery Photos

  1. cleophus

    cleophus New Member

    My wife's '04 Avalanche heater won't blow warm air at idle when we warm it up on a cold morning. The coolant temp comes up normally but the heat/defrost blows cold air until the truck starts down the road. After driving about 1/4 mile the heater works normally. Can anyone help me?
  2. pmf608

    pmf608 Active Member 1000 Posts 100 Posts

    I would suspect a plugged heater core. To fix that, all you have to do is disconnect the 2 coolant hoses going into the heater core in the engine compartment, and flush it in both directions with a garden hose until it flows properly and the water coming out is clear. Then just put the hoses back on and top up your coolant.

    Other than that, its possible that it could be the blend door motors that control between hot and cold air aren't working, but that would be more likely to be related to the amount of time it takes them to warm up enough to work rather than the distance travelled and speed of the engine.
  3. cleophus

    cleophus New Member

    Appreciate the reply...I'll start with the heater core

Share This Page