'04 Silverado Gear Indicator

Discussion in 'General Chevy & GM Tech Questions' started by OneWheelWonder, Jan 10, 2011.

  1. OneWheelWonder

    OneWheelWonder Rockstar

    Ive got an '04 K1500 base model. The gear indicator seems to be "burning out". Does anyone know if this is also just back lit from an LED?

    Anyone else have a similar problem?

    Let me know what u come up with.

    Thanks,
     
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Not it is self lit, and another common problem with the GM guage clusters. There is a recall that has been listed here on the site for the 2003-2006 models with less than 90K miles..
     
  3. OneWheelWonder

    OneWheelWonder Rockstar

    well that just sucks. I have 91K lol but thats how it goes i guess.

    Thanks for the info
     
  4. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    You can have the cluster rebuilt as well.
     
  5. OneWheelWonder

    OneWheelWonder Rockstar

    ya i have been doing a little research. Found all the parts online. as well as people that will repair them. Just havnt decided if i want to try this one myself. I work with electronics on a regular basis but would really hate to break something so important as well....
     
  6. ntbush83

    ntbush83 Rockstar 4 Years ROTM Winner 1000 Posts

    If you do decide to do it yourself you should do a write up on it! A lot of people have your same problem including myself!
     
  7. OneWheelWonder

    OneWheelWonder Rockstar

    You make a good point...Im fairly new to the site and just happend to spend some time reading through those last night. Ill see about getting the parts ordered this weekend and go from there
     

Share This Page

Newest Gallery Photos