04 Tahoe slow at low speeds

Discussion in 'Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)' started by SnH Firefighter, Sep 3, 2013.

  1. SnH Firefighter

    SnH Firefighter New Member

    hey guys ive been having some trouble with my 04 tahoe the last 3 weeks or so.. i got a problem with when i give it throttle light or heavy it gets to about 3-5MPH then it stutters to about (what feels like second gear) 20-25... the gas pump is only a year old and my lines were cleaned then too i did have a problem with that (a valve or something clogged)

    thanks for the time guys
     
  2. M-technik-3

    M-technik-3 Member

    Type of mileage on vehicle? Spark plugs worn, failing ignition lead? only at low speed or across the board?

    Fuel Mileage increase? Oh when you had the pump done, I am assuming they did the fuel filter as well.
     
  3. ChevyBoy2009

    ChevyBoy2009 Rockstar 4 Years 500 Posts

    Welcome to GMTC!
     
  4. tbplus10

    tbplus10 Epic Member Staff Member 5+ Years 5000 Posts Platinum Contributor

    Stop by an Auto Zone or other parts store that offers a free diagnostic check, have them retrieve any stored codes and make a note of them.
    That should give a good starting point to troubleshoot your problems.
    Right now the problem could be fuel, ignition, a sensor, or ???.
     
  5. SnH Firefighter

    SnH Firefighter New Member

    mileage is 115xxx Spark plugs worn and failing ignition lead havent checked yet.. only at low speeds it runs good and fast above 30mph.. and note its not all the time just maybe 30% when i hit the gas from a stand still its sluggish then after 20-25 im good no problems at all... fuel mileage is the same (i use acar app thing) and not sure on the filter... it was a gm dealer that did the work and my lines were clogged to hell and back so im sure they did change it ..l i got my own code reader and the only code im getting is a engine knock censer thats been on for about 3 years now
     
  6. M-technik-3

    M-technik-3 Member

    I would replace the plugs if they are known old, older than 40K miles on them. Clean the MAF and Throttle body. They do get gummed up with crude and get dirty. Air filter? Clean it or replace it.
     
  7. ChevyFan

    ChevyFan The Sheriff Staff Member 5+ Years 5000 Posts

    This problem came on suddenly? You said last three weeks, which sound like fuel system would be the first place to look. Everything else like new plugs needs to be done anyhow.
     

Share This Page

Newest Gallery Photos