1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

05 Sivlerado Trans Problem

Discussion in 'GM Powertrain' started by Dent Shark, Dec 14, 2009.

  1. Dent Shark

    Dent Shark New Member

    I have a 05 Silverado 4X4 W/T 52,000 miles its the 5.3 alum. with auto trans/tow package. Recently the trans seem to slip a little, I service the fluid and filter (the fluid was still clean and no residue in the pan from the disc's or clutch plates?) It still has the same problem, and it sometime will shift hard or very noisy. The truck sometime will lundge when I start it and the trans makes a weird sound. (That happens only once in a while.) I read somewhere about having the dealer reflash the computer for the hard shift from 2nd to 3rd, and I was wondering if anyone knowsof or has had the say problem.
    I have owned the truck since new and this is the first mayjor problem other than air bag sensors going bad.
  2. cliff334

    cliff334 Member

    is your service engine light on?
  3. Dent Shark

    Dent Shark New Member

    No it hasn't come on yet
  4. cliff334

    cliff334 Member

    i would still try and run a computer on it mine did the same thing but the light would come on every so often and gradually it got worse till i lost 3rd and od so i ran a comp. on it and it said my trans shift servo was bad! i coulda saved myself hundreds of dollers and alot of time by running a comp on it from the start so you should give it a shot light on or not cuz my trans codes came up even with the light off
  5. Dent Shark

    Dent Shark New Member

    Thanks I will do that.

Share This Page