1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

05 Yukon 4wd problems

Discussion in 'General Chevy & GM Tech Questions' started by wodge1, May 1, 2013.

  1. wodge1

    wodge1 New Member

    The "service 4wd" light stays on and sometimes it shifts itself into 4 low. Any ideas?
  2. Pikey

    Pikey Moderator Staff Member ROTM Winner 1000 Posts

    I would start with the switch. If you pull it apart you may find some bad solder connections.
  3. donyms

    donyms Active Member ROTM Winner 1000 Posts

    Welcome to the club, it's great to have you aboard. :glasses:
  4. wodge1

    wodge1 New Member

    thanks and I'll look at the 4wd switch today
  5. mfleetwood

    mfleetwood New Member ROTM Winner 1000 Posts

    ****Thread moved here to correct section*****
  6. SurrealOne

    SurrealOne Former Member ROTM Winner 1000 Posts

    Welcome! :great:

    Any luck?
  7. wodge1

    wodge1 New Member

    I'm finally getting back to the Yukon after just pulling fuses. I got the back of the dash switch off and don't see anything wrong, time to dig deeper
  8. Pikey

    Pikey Moderator Staff Member ROTM Winner 1000 Posts

    You might need to open the switch and check for bad solder connections INSIDE of it.
  9. wodge1

    wodge1 New Member

    I did that, that's what I meant when I said I got the back of the switch off. Apparently you cant take the circuit board out
  10. wodge1

    wodge1 New Member

    Had the transfer case oil changed and the problem went away till the wife put it in 4auto. The light came back on a while later and it shifted itself to 4low.

Share This Page