Newest Gallery Photos

  1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

06 sierra front radio speakers

Discussion in 'General Chevy & GM Tech Questions' started by twostickmutt, May 8, 2013.

  1. twostickmutt

    twostickmutt New Member

    i bought an 06 sierra 1500 last august. the 2 front radio speakers haven't worked until this week. the rear speakers always worked great. this week the fronts started working intermittently. also notice the warning chime also works for door ajar,seatbelt not buckled etc. which never worked until the speakers started working. was wondering where i should start first to try and find the problem? forgot to add that the radio is just a plain jane OEM am/fm thanks for any replies.
     
  2. dsfloyd

    dsfloyd Epic Member 5+ Years ROTM Winner Gold Member 1000 Posts

    the chimes now work because thats where you hear the chimes from. Outside of that the not working for months then suddenly working is a little odd. I would first start with checking the wiring as it could be as simple as a broken wire that for some reason is not connecting.

    OR

    Did you finally go to the Fade in the stereo and turn the speakers back on up front:rofl:. Sorry couldnt resist
     
  3. twostickmutt

    twostickmutt New Member

    hahaha. no the fade was on for the front speakers but i could do something like that. speakers were working again till about an hour ago. now they are out again. i will start checking the wiring. do you know if the radio is hard to get out of the dash. it maybe a wire plug on that. thanks for the reply.
     
  4. dsfloyd

    dsfloyd Epic Member 5+ Years ROTM Winner Gold Member 1000 Posts

    If it is similar to the one that was in my truck its really simple. pull the dash panel over instrument cluster/controls off, the are just the pull off clips. Then its like 3 screws.
     
  5. twostickmutt

    twostickmutt New Member

    thanks for all your help.
     

Share This Page