GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

1980 k20 Speedo Inop (pics & q's)

Discussion in 'GM Powertrain' started by Christopher A. Myers, Mar 11, 2012.

  1. Christopher A. Myers

    Christopher A. Myers New Member

    Joined:
    Mar 11, 2012
    Messages:
    2
    Likes Received:
    0
    Hello everyone!
    my 1980 3/4 ton 4x4 with manual trans has a speedo that is not working.
    I replaced the speedo cable and got nothing, next I assume would be the drive gear but when i crawled under, I did not see one on the t-case, instead I found this curious looking item of which I am not familiar with yet.. Can anyone tell me what this is, and if it contains my speedo gear>? Thanks in advance
    -Chris
    2012-03-11 15.02.41.jpg
    #1
  2. Boonduff

    Boonduff New Member

    Joined:
    Sep 5, 2011
    Messages:
    355
    Likes Received:
    1
    Looks like a ratio adjuster. It's just a set of gears that slow down or speed up the cable. There should be a plastic speedo gear on the output shaft of the transfercase. They wear out and strip the teeth.
    #2
  3. Christopher A. Myers

    Christopher A. Myers New Member

    Joined:
    Mar 11, 2012
    Messages:
    2
    Likes Received:
    0
    Thanks for the reply Boonduff.
    I hooked it back on and speedo worked for a few minutes, I found some play in the uinit i posted above and i think it may be my issue?

    grr i DO not know whats going on..
    #3

Share This Page