1983 Seirra

Discussion in 'Member Introductions' started by koschnell, Jul 14, 2009.

  1. koschnell

    koschnell New Member

    This Seirra has 47,000 original miles. It has a 305 with a 700r4 transmission. It was all original until I did the following modifications, replaced the manifold with an [COLOR=blue! important][COLOR=blue! important]Edelbrock[/COLOR][/COLOR] Peformer, installed 60,000 volt distributor, installed headers.

    Since these modifications my transmission slips while shifting into 2 & 3rd when excellerating to fast, after shifting it works fine and doesn't slip. It will shift fine if I let up on the [COLOR=blue! important][COLOR=blue! important]gas[/COLOR][/COLOR] as I reach the shift point.

    Could any of my modifications cause the problem or is the [COLOR=blue! important][COLOR=blue! important]transmission[/COLOR][/COLOR] having problems
     
  2. 5speedsilverado

    5speedsilverado Epic Member 5+ Years 1000 Posts

    welcome to the site!
     
  3. Mean_Green_95

    Mean_Green_95 Epic Member 5+ Years 1000 Posts

    I would say that for the age of the vehicle, getting some more power might be the culprit. But Idk...
     
  4. retired2001

    retired2001 Epic Member 5+ Years 5000 Posts

    Welcome to the site!
     
  5. bry2500

    bry2500 Epic Member 5+ Years 1000 Posts

    Welcome to the site!!!!!!
     
  6. kgibson181

    kgibson181 Epic Member 5+ Years 1000 Posts

    Welcome to the site! Got any pics of the Sierra? Post em up if you do
     
  7. canislupis69

    canislupis69 Epic Member 5+ Years ROTM Winner 5000 Posts

    Welcome to the site!
     
  8. Marty04Sierra

    Marty04Sierra Epic Member 5+ Years 500 Posts

    Welcome to the GMTC from Vancouver,WA!!
     
  9. Z71_guy

    Z71_guy Epic Member 5+ Years 1000 Posts

    welcome to the site
     
  10. ct9a

    ct9a Epic Member 5+ Years 1000 Posts

    Welcome to the site!
     

Share This Page

Newest Gallery Photos