GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER

1983 Seirra

Discussion in 'Member Introductions' started by koschnell, Jul 14, 2009.

  1. koschnell

    koschnell New Member

    Joined:
    Mar 14, 2009
    Messages:
    8
    Likes Received:
    0
    This Seirra has 47,000 original miles. It has a 305 with a 700r4 transmission. It was all original until I did the following modifications, replaced the manifold with an [COLOR=blue! important][COLOR=blue! important]Edelbrock[/COLOR][/COLOR] Peformer, installed 60,000 volt distributor, installed headers.

    Since these modifications my transmission slips while shifting into 2 & 3rd when excellerating to fast, after shifting it works fine and doesn't slip. It will shift fine if I let up on the [COLOR=blue! important][COLOR=blue! important]gas[/COLOR][/COLOR] as I reach the shift point.

    Could any of my modifications cause the problem or is the [COLOR=blue! important][COLOR=blue! important]transmission[/COLOR][/COLOR] having problems
    #1
  2. 5speedsilverado

    5speedsilverado New Member

    Joined:
    Mar 15, 2009
    Messages:
    1,238
    Likes Received:
    0
    welcome to the site!
    #2
  3. Mean_Green_95

    Mean_Green_95 New Member

    Joined:
    Apr 29, 2009
    Messages:
    1,170
    Likes Received:
    3
    I would say that for the age of the vehicle, getting some more power might be the culprit. But Idk...
    #3
  4. retired2001

    retired2001 New Member

    Joined:
    Nov 4, 2006
    Messages:
    7,611
    Likes Received:
    4
    Welcome to the site!
    #4
  5. bry2500

    bry2500 New Member

    Joined:
    Oct 7, 2008
    Messages:
    2,201
    Likes Received:
    2
    Welcome to the site!!!!!!
    #5
  6. kgibson181

    kgibson181 New Member

    Joined:
    Jul 6, 2009
    Messages:
    1,309
    Likes Received:
    1
    Welcome to the site! Got any pics of the Sierra? Post em up if you do
    #6
  7. canislupis69

    canislupis69 New Member

    Joined:
    Dec 30, 2008
    Messages:
    5,008
    Likes Received:
    1
    Welcome to the site!
    #7
  8. Marty04Sierra

    Marty04Sierra New Member

    Joined:
    Jun 30, 2009
    Messages:
    824
    Likes Received:
    0
    Welcome to the GMTC from Vancouver,WA!!
    #8
  9. Z71_guy

    Z71_guy New Member

    Joined:
    Feb 19, 2009
    Messages:
    2,068
    Likes Received:
    1
    welcome to the site
    #9
  10. ct9a

    ct9a New Member

    Joined:
    Jun 2, 2008
    Messages:
    2,818
    Likes Received:
    1
    Welcome to the site!
    #10
  11. EvilNetwork

    EvilNetwork New Member

    Joined:
    Jul 15, 2009
    Messages:
    60
    Likes Received:
    0
    Welcome. Those 700R4's were a PITA.Try re-adjusting the TV cable first. That's a more common issue for bad 3rd and 4th gear shifts. Sometimes you need to replace the cable.. it's 30 bucks generally.

    Second the throttle valve on those can cause issues, mostly of them wanting to stay ion lower gears. Shift kits are relatively cheap. I would flush it with new fluid and inspect the filter. If it looks decent, add the shift kit while you have the pan off and that will most likely solve your issue.

    If neither of those two work, the 3-4th gear clutches commonly go bad in the 700R4's which means a rebuild to repair.

    Give the first two a shot though, you'll probably solve it with those.

    --Joe
    #11
  12. bob13

    bob13 New Member

    Joined:
    Feb 6, 2009
    Messages:
    1,002
    Likes Received:
    0
    Welcome to the site!
    #12
  13. tattooed4life

    tattooed4life New Member

    Joined:
    Apr 20, 2008
    Messages:
    886
    Likes Received:
    1

Share This Page