1985 K5 Blazer 4WD drive train clunk

Discussion in 'GM Powertrain' started by Texchev85, May 8, 2010.

  1. Texchev85

    Texchev85 New Member

    Hello all, my 1985 blazer has had a bad clunk coming from the drive train for the past few months. It happens just after acceleration and also just before coming to a stop (always at a particular rpm when stopping --- about 900). It sounds like it may be coming from the rear end, but I'm not totally sure.

    Since the beginning of the year the truck has had the engine replaced with a crate 350, 700r4 tranny rebuilt, new shocks, and all 5 drive shaft (front and rear) u joints replaced. I flushed the rear differential and there were no shavings or anything out of the ordinary. I added the correct limited slip additive. I have also regreased the slip yoke.

    The truck shifts fine and drives well. The clunk (which is very pronounced) is more irritating than anything else. There is also a low vibration/grating from somewhere in the drivetrain when I let off the gas on the highway. It goes away at slower speeds.

    I'm more concerned about the clunk.

    Any thoughts would be appreciated.
     
  2. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Have you checked the backlash by trying to rotate the rear drive shaft back and forth?? I know that these rearends are famous for it getting to loose. Also try to wiggle (best word i can think of) where the rear driveshaft to ensure that the rear pinion bearing is good.
     
  3. Chris Miller

    Chris Miller Rockstar 100 Posts

    This may sound silly, but take a look at your rear shocks. Sometimes the bushings can crumble and they'll clunk like the devil and sound just like a rear end problem.
     
  4. Texchev85

    Texchev85 New Member

    I have tried to rotate the drive shaft (in park) before. There is a tiny amount of play. I wasn't sure if that was normal or not. I assumed that alot of play would be a problem, but my drive shaft will only turn about an 8th of an inch.

    Thanks
     
  5. 2COR517

    2COR517 Epic Member 5+ Years 1000 Posts

    You didn't say anything about servicing/checking the transfer case. But they are pretty reliable unless they have been thrashed on.

    I'm guessing it's in the rearend. Pull the cover off, and with rear tires off the ground and the transfer case in neutral, turn the ring gear by hand. Look closely at the diff pinion and spyder gears for play. Also, check the ring gear backlash. Basically grab the ring gear and move it up and down. Just enough to check for play, but not enough to move the pinion. Ring gear backlash should be barely visible, the spec is around .010".
     
  6. Texchev85

    Texchev85 New Member

    The transfer case was flushed about 6 months ago, and I'm diligent about checking all the fluid levels fairly frequently.

    Thanks for the tip. I will check the rear dif when I get a chance. If there's a decent amount of play in the dif what then?

    Thanks
     
  7. 2COR517

    2COR517 Epic Member 5+ Years 1000 Posts

    If the differential itself is worn, I would probably put a Tru-Trac in. It's a nice LSD, very reliable, very streetable. If the ring and/or pinion is severely worn, time for new gears too.

    If the gears all look OK, and the backlash is a little too much, probably just need to re-setup the diff/gears.
     
  8. Texchev85

    Texchev85 New Member

    I appreciate the input. Thanks!
     
  9. southernsteel87

    southernsteel87 New Member

    Stop driving immediatly! Your rear diff has no fluid! The same thing happened to me and I blew out the rear end and had to use "front wheel drive". There's a seal at the end of the axle that probably went bad, just like it did me, and allowed all the diff fluid to leak out. You'll be able to tell by looking inside your brake drums. Cost 200 bucks and 10 hours of work to replace the entire rear end.Outside in -10 degree tempuratures-lost a good 4 way and 2 socket wrenches to the cold.
     
  10. wolven0862

    wolven0862 New Member

    I agree with southernsteel87 I was not so lucky I have a 89 jimmy and as you I had a clunking noise and i did not find it eather untill it locked up at 65 MPH not a pretty site.
     

Share This Page

Newest Gallery Photos