1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

1988 GMC Suburban Seirra 1500

Discussion in 'General Chevy & GM Tech Questions' started by videorov, May 11, 2009.

  1. videorov

    videorov New Member

    I went about replacing the starter. They gave me the wrong one to start and looks like when I hooked
    that one up it blew out some fuses. I got the correct one now and place it in and then replaced
    three fuses up by the wiper motor on firewall. They were blown. I checked all fuses on panel inside and
    they are all ok.
    But I still have no power coming into the Cab. I have headlights and taillights, thats it.
    Turn the key and nothing. No radio, power windows, nothing.
    There must be some more fuses outside on the fire wall I don't see????
    Is there anymore fuses insided under the dash besides the fuse panel which I check all ok.

    It has me stumped??????????????
    Ive replaced the started before with no problems but I was giving the right starter from the start when
    I did the last one.
     
  2. CarpenterGuy

    CarpenterGuy Epic Member 5+ Years 500 Posts

    check wires and stuff. make sure they're not loose
     
  3. videorov

    videorov New Member

    No power inside

    Ive checked all wiring. It seems strange after I replaced the three fuses that something
    would work. One book I have they talk about inline fuse on some models. I don't seem to
    see any of those around the battery.
    The battery terminals are tight.
    Maybe I will check all the grounds from the battery. Im not sure if I checked all of them.
    I thought so but will check again.
    Strange all I have is headlights and taillight.
     
  4. Evan

    Evan New Member

    A lot of times the two smaller wires off the starter that run to fuse box have fuses on them I bet thats it
     
  5. videorov

    videorov New Member

    Trying to find fuses


    I wonder where they are if they are there. There not up where the rest were next to the
    firewall and wiper motor.

    If just one wire is out I would loose all power like this. Man if that isn't a crazy design
     
  6. videorov

    videorov New Member


    Found the problem. Had the small wire on starter touching something and shorting.
    Its all working ok now.

    Thank for the help.
     

Share This Page