1. Chevy Truck Forum

    Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online

    Online since 2004, we're the #1 Chevy Truck & SUV user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free

    Registering is Free and Easy! Do it today and we'll see you on the forums soon!

1988 K2500 350 auto cranks over but won't start

Discussion in 'General Chevy & GM Tech Questions' started by Grady, Aug 14, 2012.

  1. Grady

    Grady Member

    Everything has been working fine until I put in a new battery. Now it cranks and cranks but won't fire. I did reconnect the positive terminal last, does it matter? I checked the ecm/ignition fuse - it was fine. About a year ago I put in a new gas tank and fuel pump. I can hear the pump come on when I turn the key just like it always does. Should I have gas at the throttle body if I work the linkage manually from under the hood as if it were a carb? - or does the motor have to be running? I pulled a plug [it was dry and looked good] and have good spark but I couldn't even get the slightest sputter from gas or starting fluid. I know, gas, spark, and compression - I think I have all three but still I'm going nowhere. Any thoughts? - I did take it to the DIY car wash yesterday for the first time in quite a while but it started fine afterwards and again today. What about the oil pressure/fuel pump switch? Where is that thing and how do you test it?
     
    Last edited: Aug 14, 2012
  2. dipstick

    dipstick Member 2 Years 100 Posts

    Should get some fuel while cranking on the engine. Will not get any like a carb. Did you accidentally hook battery up wrong?
    Or touch pos to neg anyway? If it does not run with a prime..probably something blown in ignition circuit.
    Check fuse links at junction block.Check ecm fuse and ignition fuse. Are you sure on the spark?
     
  3. jsmith4816

    jsmith4816 Member 2 Years 100 Posts

  4. Grady

    Grady Member

    Jsmith, as I was reading your thread, I too was thinking "bad ground". This morning I went back out and took every ground I could find apart and wire brushed it. Yesterday I sprayed them with blaster but this am I went a little farther. After that I went over to my generator that I know has fresh gas and filled the blaster cap up half way and dumped it in the throttle body. The gas I dumped in yesterday was from a can that was almost empty and apparently not good enough. I think that's why it wouldn't fire on ether after that gas but I had good spark on the #1 plug - the only one I pulled. I tried starting it after dumping the gas in and though it didn't fire right up, I did at least detect some firing and the attempt to start so I cranked on it again and after some pumping of the pedal and some colorful encouragement, she fired up and ran. Even though it had been starting every time previously, it always cranked over more than it did before it sat for a while when it wouldn't pass inspection. I never really understood why until this am. Now, it starts like it used to, on the first turn of the key instead of after several revolutions of the motor. Dipstick, I know I didn't reverse the connections but I thought I might have done something to the ecm or something electronic by not hooking up the positive first because you get that sparking when you hook it up last. That's why I was surprised to see spark when I pulled the #1 plug. I bet if I pulled some plugs farther back on the motor, they would have been wet with the bad gas. I'm still not clear on whether or not I should see gas squirting into the throttle body when I move the throttle linkage by hand [because I didn't] I guess I should climb back up there and have another look now that it's working. Thanks for helping out, I was really scratching my head.
     

Share This Page