1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

1990 Chevy 1500 Driving me INSANE

Discussion in 'Chevy C/K Truck Forum' started by bonehead79, Nov 10, 2009.

  1. bonehead79

    bonehead79 New Member

    someone please help i have a 1990 w/t chevy 1500 pu,4.3 tbi m/t , it all started one day and the truck started to hesitate and never been the same since and i have changed almost every part on the system,it keeps coming up code 45 its a rich code,but the truck put me broke lol,I have put these parts new,rebuilt computer,o2 sensor,plugs,wires,new distributor,coil,map sensor,tps sensor,iac sensor,and the fuel pressure is 13 psi at all times,3 sets of injectors,cat converter,computer chip,Im so fustrated i dont know what to do someone please help.Buy the way when the service engine light comes on the truck runs excellent all help is appreciated
  2. retired2001

    retired2001 New Member 1000 Posts 100 Posts

    Welcome to the site! I'm sure that you will be able to get some help with your problems from some of the folks on the site, as they are knowledgable and like to help.
  3. okysmokey911

    okysmokey911 New Member 100 Posts

    Have you adjusted the tps sensor? For some reason when they sent mine they had it set way too high. Kind of sounds like a timing problem too.
  4. booger57

    booger57 New Member

    I have a 93 with a 350, and I finally took it to the dealer. They came up with a bad EGR valve. I replaced it and my truck runs fine.
  5. x1LSUTigerfan

    x1LSUTigerfan New Member

    i had to replace my cap and rotor, new plugs, new tps switch and coolant temperature sensor, egr valve and relay i did this all at seperate time and in this order egr valve, egr relay,tps switch, plugs, coolant temperature sensor then cap and rotor i didnt start to run right until i changed the cap and rotor and coolant temp sensor so give those a try

Share This Page