1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

1990 Silverado Horn problem

Discussion in 'GM Electrical Tech' started by quackman, Aug 4, 2012.

Random Gallery Photos

  1. quackman

    quackman New Member

    It has been a while since I have been on so yall forgive me, I have a 1990 Silverado 4x4 that my son drives (my first new truck ever, 76000 original miles!!) he advised me his horn quit working so I checked it out, could not locate a fuse or relay, I removed the horn button to find a wire with a spring on it not hooked to anything on the spring end, does this hook up, is the fuse marked as something else and where would the relay be? I would like to get it working as I am a fanatic about having everything working in my vehicles, which are all Chevy's. Can anyone help me with this ??
    I would appreciate all the information your great minds will allow me!
  2. Kady

    Kady New Member 100 Posts

    Check and make sure all other accesories work... That'll give ya an idea if its the fuse or not... IF you only checked the panel that's inside the truck between the door jam and the dash, also check the fuses under the hood. If you happen to have the owner's manuel, check that.
  3. quackman

    quackman New Member

    Thanks I will do that, I do think all the other accessories do work
  4. txtruck91

    txtruck91 New Member

    if all others work try placing the spring back in the hole it sit's in. i know when mine stoped i pulled it out and placed it back in a few time and i must have got it in there right this time. i have not had any problem and it's been a year now.
  5. quackman

    quackman New Member

    Ok guys , it has been repaired, txtruck91 hit the nail on the head, spring was out of the hole, I did not now where that thing actually went but I do now, thank you all for your assistance!!!!!!!!!!
  6. Kady

    Kady New Member 100 Posts

    Wahhh, my horn doesn't work now! Fuses are fine... what next!?
  7. ChevyFan

    ChevyFan Administrator Staff Member 1000 Posts

    Did your spring come out of the hole too?

Share This Page