1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

1991.GMC burb 4x4 tbi 350 timing issues

Discussion in 'GM Powertrain' started by Shawns gmc, Feb 17, 2014.

  1. Shawns gmc

    Shawns gmc New Member

    Hello to all of you here on chevy talk i googled my problem and vola here i am . Can anyone please help me im having a pinging problem with my burb 350 tbi 1991 i bought this truck two years ago from the original owner its a 91 but only has 118xxx miles i currently use it for a plow truck my problem started two days ago it all of a sudden started pinging bad im mechanicly inclined but not much with computer cars or truck when i bought the truck i tuned it up myself cap wires rotor plugs was running just fine until two days ago .CAN ANYBODY HELP ME PLEASE to figure out what happend thank you in advance shawns gmc...
  2. BurbanMan

    BurbanMan Member

    Does your dizzy have a vacuum advance? Initial timing Iirc is 0*
  3. Shawns gmc

    Shawns gmc New Member

    timing issue ?

    No vacume advance . What would make it all of a sudden start pinging like it's hot but it isn't hot but it
  4. BurbanMan

    BurbanMan Member

    It may also be time for a timing chain. Could be bad fuel. There's a lot of things to factor in
  5. Crawdaddy

    Crawdaddy Moderator Staff Member Platinum Contributor 1000 Posts

    I've been having similar issues with my 1991 Suburban. When I first start the truck up, it wants to die and backfires, but once it warms up for a minute, it runs perfectly. Are those symptoms to yours? My timing is somewhere around 3* BTDC but should be at 0*. I'm going to re-time it when I get a chance to make sure that isn't the issue.

    EDIT: Also moved this to Powertrain since there's really no introduction.
  6. Shawns gmc

    Shawns gmc New Member

    today i change the temp pressure switch and when i started it up it started hard i had to hold the gas pedal half way down . I thought it was running better but when i took it for a ride it started pinging again with only 118000 miles would it/could it need a chain i always got alot more miles out of a timming chain Any help would be forever gr8ful if anyone has the time please E-mail me THANKS in advance Shawn shawnhammes45@gmail.com

Share This Page