1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

1993 silverado 2wd 5.0 tbi shuts off will start later runs great the shuts off HELP?

Discussion in 'Chevy C/K Truck Forum' started by emmett, Nov 7, 2013.

  1. emmett

    emmett New Member

    I have 1993 Silverado 5.0 TBI, I have replaced Get ready.. FUEL PUMP,FUEL FILTER, FUEL RELAY, PLUGS/WIRES. DIST CAP/ROTOR,TPS,IDLE CONTROL,EGR VALVE,REBUILT THROTTLE BODY,BOTH TEMP. SENDERS,OIL PRESSURE SENDING UNIT,THE ECM (COMPUTER) Have cleaned all grounds that I could find . When it shuts off it acts like it is not getting fuel. The dash lights go out, turn key off and back on lights come back on will not start Engine turns over and it is getting fire. IS THERE another relay that can stop the fuel pump? could it be the key switch with a short ? ( I have wiggle all of the wires) You can spray a little fuel in the TB and some times it starts runs great till it quits. Can anyone help ? My hair is turning gray. Have too much money in it to burn.:grrrrrr:
  2. leb01amg

    leb01amg New Member

    I see you replaced the distributor cap and rotor but did you replace the distributor & spark module? You may have a bad module which is under the distributor. When you replaced the ECM, did you receive a new computer body with motherboard and you had to move the old chip to the new computer body?
  3. emmett

    emmett New Member

    YEA, TRUCK IS RUNNING, ALL MOST LIKE NEW WITH ALL OF THE PARTS I PUT ON IT fOUND THE GRAY WIRE FROM THE OIL SENDING SENSOR GOING TO THE PUMP RELAY WITH NO INSTALLATION ON IT INSIDE THE WIRING HARNESS.. FIXED THAT BUT STILL DID NOT STAY RUNNING. IT WAS THE SPARK MODULE LIKE LEBOIAMG SAID . WENT TO PULL-A-PART SALVADGE YARD GOT ONE FOR $ 7.50.-- I DID CHANGE THE PROM FROM THE OLD COMPUTER TO THE ONE I GOT. HAVE A GOOD COMPUTER IF ANYONE NEEDS IT. PS; THE TRUCK HAS 268,000 MILES ON IT MOST EVERYTHING I PUT ON IT ,IT NEEDED. THANKS FOR YOUR HELP:money:
  4. RayVoy

    RayVoy Active Member 1000 Posts

    Ok, forgive me for being blunt, but you just guessing.

    You need to find out if it's fuel, or spark.

    If when the engine dies and will not start, have you tried spraying a little ether (starting fluid) into the tb to see if it starts. If it starts it's probably a fuel problem.

    Start with a fuel pressure gauge, when the engine dies, do you have pressure, or did it fall off just before the engine dies.
  5. emmett

    emmett New Member

    Thanks ray, i had did all of the things that you said it was a fuel problem but i didn't know why ??.--when you turn the key to start, the fuel relay activates the power to the fuel pump then shuts off,when the dist. Rotates it sends a pulse through the spark module to the computer to re-activate the power to the fuel pump via- the gray wire back to the fuel pump to keep it going. The spark module fixed the problem the truck is going good.i got a extra one at the salvage just in case. I am 75 years young when i was changing the spark module i was setting on top of the motor i sure was hard to getting back down.thanks for your input .ec
  6. RayVoy

    RayVoy Active Member 1000 Posts

    Hahaha, good story, glad your back in business.

Share This Page