1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

1995 K2500 Sub 4X4 issues

Discussion in 'GM Powertrain' started by 1991 Suburban, Feb 20, 2011.

  1. 1991 Suburban

    1991 Suburban Rockstar 100 Posts

    Alright, hopefully you guys can give me a little insight here...My Dad has a '95 K2500 Sub which I am trying to figure out what is going on with the 4wd.

    Dads 4wd activation has been fairly intermittent to say the least. The other day he was getting ready to go play on the river and it would not engage at all. He hasn't needed 4wd for the last few days, but we got a little snow this morning, and he wanted me to check it out.

    First thing I did was go check the fuse panel. Yup, it blew the 4X4 fuse, so I replaced it. Started it and tried to engage the 4wd. Nothing. Opened the fuse panel again, and it had already blown the new fuse.

    I know there is a bad wire somewhere, but I really don't like trying to find things laying in the snow, so I was hoping somebody would have a little input as to WHERE this wire may be? Is this a common issue on this era truck?

    Thanks guys!
  2. 1991 Suburban

    1991 Suburban Rockstar 100 Posts

    Okay, I just thought of something...Is there any chance that the actuator is bad and is blowing fuses? Or would it more likely be bad wiring?
  3. DAREDEVIL

    DAREDEVIL Rockstar 4 Years 1000 Posts

    YEP, your on to something with the seliniod/actuator.

Share This Page