1996 5.7L (350cid) V-8 Vortec Fuel Pressure Specs

Discussion in 'GM Powertrain' started by murdog94, May 10, 2011.

  1. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Alright guys im relying on someone to help me out here with the actual PER GM specs for the Vortec Fuel pressure. I have done alot of searching and know that anything over 55 etc is good however my buddys truck (1996 Chevy K1500 5.7L 4L60E) has a P0300 code and after alot of digging i checked the fuel pressure. Key on/engine off 60PSI, Engine idle (700ish RPM) 52PSI, Reving engine drops to 48PSI then goes back to 50PSI...
    as i said i did alot of digging on the site and around the web, and the numbers were all over the place. I know key on 55-60 is the keyish, and idle is around the same. But what is confilicting is how much if at all it is supposed to rise etc. Since i dont want to replace a pump without solid information. Also for anyone else who may need this info.
    ****note**** im 99% that the fuel pump has had it but i hate any guessing when its not my money.
     
  2. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    Mike did you do a leak down test on the fuel line?
     
  3. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    My 'Burb is also around 60psi with ign. on but engine not running.
     
  4. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    We a leak down test there isnt any loss. Last night we replaced the plugs (he was running E3s after i told him to put delcos in some people Lol) and we had 2 fouled plugs. And it is still missing and we did a FP test again. 55psi ignition on. and running 51, and when you tromp the throttle it goes to 58PSI and promptly drops to less than 50. so the pump is shot. no way around it. we will be doing it on Friday.
     
  5. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    Mike, I've seen dirty fuel filters mess with fuel pressures, have you tried a new f/filter?
     
  6. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Yep the filter is new, as is the pump now. I have traced it down the the return in the spider injector assembly. Currently there are cyls that are running very rich, and the other 6 are so lean that they dont even look like they are used. so time to get some work done.
    We are going to switch to the MPFI system. and work with that and then go from there since everything else is checked out.
     
  7. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    OH how much fun i had this weekend. We replaced the SFI to MPFI which is a slick set up and wow what a difference in power and response. Now for the not so good news. After changing to MPFI we still had a P0300 code, and a P0122 Code (Throttle Position sensor) which was actually new. So we did replace the TPS since it litterally fell apart and the tranny had been banging gears for a while anyhow. That made it run a bit better. So i pull the #2 and #4 cyl plugs and they are both black and smell like gas. UGH. spark problem (the Fuel pressure was holding steady and building well over 65 when revved so that was fixed. My buddy stubbornly argued that he had replaced the cap and rotor, and crank sensor (after calling a shop that told him to replace a bunch of crap that didnt need to be replaced) so he stil had the old cap and we put that on, and bang the motor runs like brand new with more power and hopefully a bit better milage thanks to the MPFi and the Platinum plugs.
     
  8. silveradotrailblazer

    silveradotrailblazer Epic Member 5+ Years ROTM Winner 5000 Posts

    So is this guy still your buddy? LOL. Glad you got it fixed.
     
  9. murdog94

    murdog94 Epic Member 5+ Years 5000 Posts

    Yep he is.. he has helped to hold to the tools on many of my projects. Plus we fixed his exploder which his daughter didnt want to drive anymore. Did a radiator change easy enough. Not so.. the radiator that he got had 2 holes in it. so i did the cooler roll and no more leaks for now. Ugh what an adventure. And it was MN fishing opener and i got a whoping 5 hours of fishing in on a 4day weekend.
     

Share This Page

Newest Gallery Photos