1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

1996 suburban 1500 turn signal issue

Discussion in 'Chevy Suburban Forum (GMC Yukon XL)' started by barryT, Nov 13, 2008.

  1. barryT

    barryT Member

    Well I am new here and I need a little help. About three days ago the turn signal flasher relay under the dash neer the floor board started clicking all the time. It stops some times but is on most of the time. I replaced the flasher relay and the problem still persists. When it is clicking the turn signals are not coming on. I did buy the turn signal/ cruisercontrol / wiper switch. I haven't installed it yet, but will this fix my problems? I forgot to mention my turn signals still function fine when activated. Just when the turn signals are not activated the relay is clicking away by itself.



    Thanks
    barry
  2. Zabob44

    Zabob44 New Member

    Maybe your getting back feed power from something else..have you looked at a diagram to see what else is fed off that circuit? Check power at the relay maybe your just getting partial voltage from somewhere else.
  3. dwill3015

    dwill3015 Epic Member 5+ Years ROTM Winner 1000 Posts

    Welcome to the site!
  4. barryT

    barryT Member

    When the noise goes away and I touch the turn signal switch assembly I starts again.

    -barry
  5. retired

    retired Rockstar 100 Posts

    It is possible for the combination switch to short out but try replacing the flasher.
  6. barryT

    barryT Member

    I did replace the flasher and there is no change. Napa doesnt except returns either. Well at least I have a spare right? :)

    -barry
  7. retired

    retired Rockstar 100 Posts

    Flashers are cheap anyway.
  8. Zabob44

    Zabob44 New Member

    sounds like a combination switch problem to me then
  9. JDF

    JDF New Member

    Hi Everyone, I'm a new member here, I have a 96 K1500 and 97 Subn. I have a similar flasher problem with my 96 K1500. The blinking stops when I use the brake pedal, and the turn signals work, but It constantly clicks while driving. I replaced the flasher unit and still persists I wonder if you (Barry) had any success with your similar problem. Thanks

    John
  10. GaryL

    GaryL Epic Member 5+ Years ROTM Winner 1000 Posts Platinum Contributor

    My Dad's 96 Silverado did the same thing. I endend up replacing the turn signal switch. You have to remove the air bag and steering wheel to get to it.

Share This Page