Newest Gallery Photos

  1. Welcome To GMTruckClub.com!

    The #1 Chevy Truck Forum Online
    Online since 2004, we are the #1 Chevy Truck & SUV forum and user community. If you have any questions about your Chevy or GMC Truck, SUV or Crossover, or just want to connect with other GM owners and enthusiasts around the world, you've found the best place on the internet to do that.

    Join Today ~ It's Free
    Registering is Free and Easy! Hope to see you on the forums soon!

1996 Tahoe Issues..PLEASE HELP!

Discussion in 'Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)' started by Jess' Hoe, Nov 3, 2011.

  1. Jess' Hoe

    Jess' Hoe New Member

    I have a 1996 chevy tahoe. Recently my truck was hard to start..it eventually starts but takes a minute then fires up. When it does start, it revs up really high to about 1500 rpm's. When i put it in gear it wants to drive itself and the brakes dont feel like they wont too well. This goes on for a few minutes then stops. I noticed my fuel pressure gauge also moves up and down. Does anyone know what this may be? I am going to take it into the shop but I wanted to check with you all to see if you have had this problem or know what it may be so i can get started on it. Any help or suggestions is greatly appreciated! Thank in advance!
  2. 2COR517

    2COR517 Epic Member 5+ Years 1000 Posts

    Do you mean the fuel level gauge?

    Does it only do this when hot?
  3. Jess' Hoe

    Jess' Hoe New Member

    It does it with every start whether its hot, cold...etc. Its almost like its dead..then starts then revs up...and feels like it almost has too much power as i put it in drive, and it takes off on its own without me pushing the gas pedal...and the brakes are weak...

    no the fuel pressure guage..
  4. 2COR517

    2COR517 Epic Member 5+ Years 1000 Posts

    These trucks need about 55 psi to even think about running. What's your key on/engine off pressure? What is it at idle?
  5. Jess' Hoe

    Jess' Hoe New Member

    I will have to check that this weekend. I will let yo know. If its lower than 55psi, then i will start by replacing the fuel filter? that is probably due to be done anyway.
    Last edited: Nov 4, 2011
  6. silverhobey

    silverhobey Rockstar 3 Years 500 Posts

    hopefully the fuel filter is causing most of the issue, good luck, hope its' a quick fix for you !!! Brian
  7. Jess' Hoe

    Jess' Hoe New Member

    Thanks guys! I hope so too! So say its not that though....any other ideas you can throw out there? Things to check?
  8. Caddiac

    Caddiac Rockstar 3 Years 1000 Posts

    There is one other problem that would explain it running away like that at high revs. It could also explain the breaks but getting better after a few stops I will have to think about for a while. If you pull the vacuum boost hose off the engine will rev high so I am thinking a vacuum leak could also make it exhibit some of these symptoms.

    Fuel pressure should be 55 - 62 psi with the fuel pump running.
    Fuel pressure should hold steady between 48 -52 psi after the fuel pump cuts off

    Good luck!
  9. Jess' Hoe

    Jess' Hoe New Member

    I will have the hose checked as well. We decided to start with the easy and change the fuel filter. It NEEDED it! The truck still has a hard start but its not as bad and doesnt rev as high but still does. It could be a combo.

    Caddiac--did you think of anything else?
  10. Jess' Hoe

    Jess' Hoe New Member

    Well the noise went away for a bit then it wouldnt start. Turning over but not starting. Figured out its probably the fuel pump. NOW.....the problem is, my gas tank and fuel lines need replaced as well.....i have had all the gas lines replaced but the ones at the tank...

    Does anyone know if there is a specific name for those lines so i dont e=order the wrong ones? They are a GM special order part...I wanna do it right. Thanks in advance for any help you can give me!
    Last edited: Dec 8, 2011

Share This Page